[packages] add krb5, the MIT Kerberos 5 implementation (#6101)
[openwrt/svn-archive/archive.git] / net / dircproxy / Makefile
index da6ae4daa0225ab5cc2865c4e127d79b54e24985..aca28b4598f6d0a7f40f2afce0d29037ea294e99 100644 (file)
@@ -4,21 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dircproxy
-PKG_VERSION:=1.2.0-beta2
+PKG_VERSION:=1.2.0-RC1
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz
-PKG_SOURCE_URL:=http://dircproxy.securiweb.net/pub/1.2/
-PKG_MD5SUM:=850443437f709276ff21a173bbf98456
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://dircproxy.googlecode.com/files/
+PKG_MD5SUM:=4fe2e82619c7b575599bfb236adbd872
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,7 +22,7 @@ define Package/dircproxy
   SECTION:=net
   CATEGORY:=Network
   TITLE:=An IRC proxy server
-  URL:=http://dircproxy.securiweb.net/
+  URL:=http://dircproxy.googlecode.com/
 endef
 
 # uses Build/Configure/Default
@@ -40,7 +35,7 @@ endef
 
 define Package/dircproxy/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/dircproxy{,-crypt} $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dircproxy{,-crypt} $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,dircproxy))