[packages] mysql: use proper proc file in hostname patch
[openwrt/svn-archive/archive.git] / net / dsniff / Makefile
index d6a15596075e72007e54ba7796b54d98845ac582..6b645043bc7ee155d10aa9b00c149693bab928b3 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,10 +14,8 @@ PKG_RELEASE:=2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.monkey.org/~dugsong/dsniff/beta
 PKG_MD5SUM:=2f761fa3475682a7512b0b43568ee7d6
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-2.4
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,12 +23,14 @@ define Package/dsniff
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libpcap +libnids +libnet0 +libopenssl +libgdbm
-  TITLE:=A collection of tools for betwork auditing and penetration testing
-  DESCRIPTION:=\
-       A collection of tools for betwork auditing and penetration testing.
+  TITLE:=A collection of tools for network auditing and penetration testing
   URL:=http://www.monkey.org/~dugsong/dsniff/
 endef
 
+define Package/dsniff/description
+       A collection of tools for network auditing and penetration testing.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-gdbm="$(STAGING_DIR)/usr" \
@@ -53,7 +52,7 @@ endef
 
 define Package/dsniff/install  
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP)  $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
 endef