[packages] dsniff: fix compilation against librpc
[openwrt/svn-archive/archive.git] / net / dsniff / Makefile
index 6b645043bc7ee155d10aa9b00c149693bab928b3..a26f6fe833cee91376b578242c8bde0749f0a80f 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dsniff
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcap +libnids +libnet0 +libopenssl +libgdbm
+  DEPENDS:=+libpcap +libnids +libnet0 +libopenssl +libgdbm $(LIBRPC_DEPENDS)
   TITLE:=A collection of tools for network auditing and penetration testing
   URL:=http://www.monkey.org/~dugsong/dsniff/
 endef
@@ -31,6 +31,8 @@ define Package/dsniff/description
        A collection of tools for network auditing and penetration testing.
 endef
 
+TARGET_LDFLAGS += $(LIBRPC)
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-gdbm="$(STAGING_DIR)/usr" \