Merge pull request #4948 from ldir-EDB0/remwireguard
[feed/packages.git] / net / e2guardian / Makefile
index 0823d95fc8e4702a607cb55d64bea41d11774c11..14462a460bd0a10ab8a27c27461a5dd1445308b4 100644 (file)
@@ -8,16 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2guardian
-PKG_VERSION:=3.0.4
+PKG_VERSION:=3.2.0
 PKG_RELEASE:=1
 
 PKG_LICENSE:=GPL-2.0
 PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
 PKG_SOURCE:=v$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/e2guardian/e2guardian/archive/
-PKG_MD5SUM:=f8ffac7ac4f040b672cc4e62121bf4c5
+PKG_SOURCE_URL:=https://github.com/$(PKG_NAME)/$(PKG_NAME)/archive/
+PKG_HASH:=cae011aacf6b250fc021c861fe46e15310349c474bca4553c0f829620e53e3bf
 
+PKG_FIXUP:=autoreconf
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
@@ -45,11 +46,15 @@ CONFIGURE_VARS += \
 
 CONFIGURE_ARGS += \
                --with-sysconfsubdir=e2guardian \
-               --with-proxyuser=root \
-               --with-proxygroup=root \
-               --enable-pcre=yes
+               --with-proxyuser=nobody \
+               --with-proxygroup=nogroup \
+               --enable-pcre=yes \
+               --with-piddir=/tmp/e2guardian/ \
+               --enable-sslextralists=no \
+               --enable-sslmitm=no
 
 define Build/Configure
+       ( cd $(PKG_BUILD_DIR); ./autogen.sh )
        $(call Build/Configure/Default,$CONFIGURE_ARGS)
 endef