asterisk: no reason to download sounds on each build
[openwrt/svn-archive/archive.git] / net / ethtool / Makefile
index f7ea026efbcb902bf1e5451f2fd8ec217170f82f..8cded281bcd49014ee5b06d2ccc3e16b8a422b0c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ethtool
-PKG_VERSION:=6
+PKG_VERSION:=2.6.38
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/gkernel
-PKG_MD5SUM:=3b721ec27f17ebf320ba8c505cf66d9c
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@KERNEL/software/network/ethtool
+PKG_MD5SUM:=4cc35c59e4fd0defff768f9f59fa41ad
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -21,24 +24,18 @@ define Package/ethtool
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Display or change ethernet card settings
-  URL:=http://sourceforge.net/projects/gkernel/
+  URL:=http://www.kernel.org/pub/software/network/ethtool/
+  MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
 endef
 
 define Package/ethtool/description
-       ethtool is used for querying settings of an ethernet device and changing them.
-endef
-
-# uses GNU configure
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+ ethtool is a small utility for examining and tuning your ethernet-based
+ network interface.
 endef
 
 define Package/ethtool/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ethtool $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ethtool $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ethtool))