[package] update gpsd to 2.94, add config, init and hotplug scripts, patch from Rober...
[openwrt/svn-archive/archive.git] / net / flow-tools / Makefile
index f5d8693ea659952294a20371880f08f5003ae50a..6323c934e56cbea2f3187329233c82447d856416 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
@@ -15,9 +14,8 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.eng.oar.net/pub/flow-tools/
 PKG_MD5SUM:=c9e0a8b53c79611b6bffcb9d510a5a38
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=+zlib
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,14 +23,16 @@ define Package/flow-tools
   SECTION:=net
   CATEGORY:=Network
   TITLE:=flow-tools
-  DESCRIPTION:=\
-       Flow-tools is a software package for collecting and processing \\\
-       NetFlow data from Cisco and Juniper routers.
   URL:=http://www.splintered.net/sw/flow-tools/
 endef
 
+define Package/flow-tools/description
+       Flow-tools is a software package for collecting and processing 
+       NetFlow data from Cisco and Juniper routers.
+endef
+
 define Build/Compile
-       $(call Build/Compile/Default)
+       $(call Build/Compile/Default,all)
 endef
 
 define Package/flow-tools/install