[net] Routing and Redirection: Moved link level discovery daemon to Routing and Redir...
[openwrt/svn-archive/archive.git] / net / gmediaserver / Makefile
index decabd38343919770b23e39e637fdcefd46c0a3e..ab51e33b9b98369428d396361c6bf05fec372fdc 100644 (file)
@@ -4,24 +4,27 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmediaserver
-PKG_VERSION:=0.12.0
+PKG_VERSION:=0.13.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://savannah.nongnu.org/download/gmediaserver/
-PKG_MD5SUM:=7f99a9b2e32c41acf7e71eb0bc0840e9
+PKG_MD5SUM:=c422de386331e2a1a859d45f6fa270a3
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/gmediaserver
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+id3lib +libiconv +libmagic +file +libupnp +libuuid
+  DEPENDS:=+id3lib +libmagic +file +libupnp +libuuid +uclibcxx +zlib $(ICONV_DEPENDS)
   TITLE:=An UPnP music media server
   URL:=http://www.nongnu.org/gmediaserver/
   SUBMENU:=multimedia
@@ -37,7 +40,7 @@ endef
 CONFIGURE_ARGS += \
        --disable-rpath \
        --enable-threads=posix \
-       --with-libiconv-prefix="$(STAGING_DIR)/usr/lib/libiconv" \
+       --with-libiconv-prefix="$(ICONV_PREFIX)" \
        --without-libintl-prefix \
        --with-id3lib="$(STAGING_DIR)/usr" \
        --with-libupnp="$(STAGING_DIR)/usr" \
@@ -47,8 +50,7 @@ CONFIGURE_ARGS += \
 MAKE_FLAGS += \
        AR="$(TARGET_CROSS)ar" \
        LTLIBICONV="" \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install \
+       DESTDIR="$(PKG_INSTALL_DIR)"
 
 define Package/gmediaserver/install
        $(INSTALL_DIR) $(1)/usr/sbin