postgresql: Parallel build fixes
[openwrt/svn-archive/archive.git] / net / httping / Makefile
index 9515a63e8c5296d749606dd02be9b16f6c63281c..0a11935adfdaec809acf1eb37f18ce9111e7e06c 100644 (file)
@@ -1,23 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
-PKG_VERSION:=1.2.2
+PKG_VERSION:=1.4.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
-PKG_MD5SUM:=cde335c0110fb1b156afdf80ff5ade1d
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.vanheusden.com/httping
+PKG_MD5SUM:=e36bb30bd758c766d7260bdde6fe6450
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,20 +28,17 @@ define Package/httping
 endef
 
 define Package/httping/description
-       Give it an url, and it'll show you how long it takes to connect, send a 
-       request and retrieve the reply (only the headers). Be aware that the 
+       Give it an url, and it'll show you how long it takes to connect, send a
+       request and retrieve the reply (only the headers). Be aware that the
        transmission across the network also takes time!
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-       )
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
 
-define Package/httping/install 
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/httping $(1)/usr/sbin/
+define Package/httping/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/httping $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,httping))