fix compile
[openwrt/svn-archive/archive.git] / net / httping / Makefile
index f92015b2e6034a552d2520fb7aafd29d32d8711c..0d8692d54f1c3b583453750a3a8442f08ec2563d 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=httping
 PKG_VERSION:=1.0.10
 PKG_RELEASE:=1
-PKG_MD5SUM:=998b00b8babeb3196d28c20ad87d9c15
 
-PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
+PKG_MD5SUM:=998b00b8babeb3196d28c20ad87d9c15
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -25,21 +26,20 @@ define Package/httping
   CATEGORY:=Network
   DEPENDS:=+libopenssl
   TITLE:=Httping is like 'ping' but for http-requests
-  DESCRIPTION:=Httping is like 'ping' but for http-requests.\\\
-Give it an url, and it'll show you how long it takes to connect, send a\\\
-request and retrieve the reply (only the headers). Be aware that the\\\
-transmission across the network also takes time!\\\
+  DESCRIPTION:=\
+       Give it an url, and it'll show you how long it takes to connect, send a \\\
+       request and retrieve the reply (only the headers). Be aware that the \\\
+       transmission across the network also takes time!
   URL:=http://www.vanheusden.com/httping/
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) -f $(PKG_BUILD_DIR)/Makefile$(SSL_ENABLE) \
-               CC="$(TARGET_CC)" STAGING_DIR=$(STAGING_DIR)
+define Build/Compile
+       $(call Build/Compile/Default)
 endef
 
 define Package/httping/install 
-       mkdir -p $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/httping $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,httping))