Add luasocket, patch from OrazioPirataDelloSpazio
[openwrt/svn-archive/archive.git] / net / httping / Makefile
index 0d8692d54f1c3b583453750a3a8442f08ec2563d..2b757e7d89f26e7ca0472d49c14be10fef385de2 100644 (file)
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
-PKG_VERSION:=1.0.10
+PKG_VERSION:=1.2.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
-PKG_MD5SUM:=998b00b8babeb3196d28c20ad87d9c15
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=2fa68b95d190a9e101232792df49e1ad
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,15 +23,19 @@ define Package/httping
   CATEGORY:=Network
   DEPENDS:=+libopenssl
   TITLE:=Httping is like 'ping' but for http-requests
-  DESCRIPTION:=\
-       Give it an url, and it'll show you how long it takes to connect, send a \\\
-       request and retrieve the reply (only the headers). Be aware that the \\\
-       transmission across the network also takes time!
   URL:=http://www.vanheusden.com/httping/
 endef
 
+define Package/httping/description
+       Give it an url, and it'll show you how long it takes to connect, send a
+       request and retrieve the reply (only the headers). Be aware that the
+       transmission across the network also takes time!
+endef
+
 define Build/Compile
-       $(call Build/Compile/Default)
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+       )
 endef
 
 define Package/httping/install