Merge pull request #4940 from diizzyy/patch-95
[feed/packages.git] / net / ibrdtn-tools / Makefile
index 83fcc617c6c7022459b3443cc2e91aacc82ccbf7..3ef388136710f0e1c8cebfd47c3edd0a34fd561b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ibrdtn-tools
-PKG_VERSION:=0.12.1
+PKG_VERSION:=1.0.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
-PKG_MD5SUM:=0ce0c6e754263919ad48661967c2f6fd
-PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
+PKG_HASH:=eab066cf15f9c322d769c6c9c58adfb474cba7d446fd12e8de5ff6344376795b
+PKG_MAINTAINER:=Johannes Morgenroth <jm@m-network.de>
 PKG_LICENSE:=Apache-2.0
 
 PKG_INSTALL:=1
@@ -33,6 +33,9 @@ define Package/ibrdtn-tools/description
  and a tools to ping a DTN node (dtnping).
 endef
 
+CONFIGURE_ARGS += \
+       --without-libdaemon
+
 define Package/ibrdtn-tools/install
        $(INSTALL_DIR) $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtnping $(1)/usr/bin/dtnping