fix squid compile, cleanup
[openwrt/svn-archive/archive.git] / net / ifstat / Makefile
index 6c3c849844f2f98b7d284d6e9aac5714eb616de3..bc3bba4d4893bf7c6972b3e3f5fff37eb8e4f846 100644 (file)
@@ -5,7 +5,7 @@
 # See /LICENSE for more information.
 #
 #
-# $Id:$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -30,6 +30,22 @@ define Package/ifstat/description
  Network interface bandwidth usage, with support for snmp targets
 endef
 
+CONFIGURE_ARGS += \
+       --with-proc=yes \
+       --with-snmp=no \
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); touch \
+               config.h.in \
+               configure \
+       );
+       $(call Build/Configure/Default)
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) all
+endef
+
 define Package/ifstat/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ifstat $(1)/usr/bin/