packages: igmpproxy: Add configuration of igmpproxy through uci
[openwrt/svn-archive/archive.git] / net / igmpproxy / Makefile
index a4614a65c680f409f8b0c93910522706fca0c821..de081cc33d71a3977a5b0d3d7dba696b936cb03a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=igmpproxy
 PKG_VERSION:=0.1
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/igmpproxy
@@ -33,7 +33,7 @@ define Package/igmpproxy/description
 endef
 
 define Package/igmpproxy/conffiles
-/etc/igmpproxy.conf
+/etc/config/igmpproxy
 endef
 
 TARGET_CFLAGS += -Dlog=igmpproxy_log
@@ -45,8 +45,8 @@ define Build/Compile
 endef
 
 define Package/igmpproxy/install
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_CONF) ./files/igmpproxy.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/igmpproxy.config $(1)/etc/config/igmpproxy
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/igmpproxy.init $(1)/etc/init.d/igmpproxy
        $(INSTALL_DIR) $(1)/usr/sbin