[packages] ... and readd @!LINUX_2_4 change to speedtouch-usb-firmware
[openwrt/svn-archive/archive.git] / net / iperf / Makefile
index 9ac017fbf470873d935bb461d2d7aed8f899de35..cddb35756231932107319c422b2b90ff123560f1 100644 (file)
@@ -1,39 +1,38 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iperf
-PKG_VERSION:=2.0.2
-PKG_RELEASE:=2
+PKG_VERSION:=2.0.5
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
-PKG_MD5SUM:=bb658aba58a5af0356f5b1342dfe8f53
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=44b5536b67719f4250faed632a3cd016
+
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/iperf/Default
-  SUBMENU:=Monitoring
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:= +uclibcxx
   TITLE:=Internet Protocol bandwidth measuring tool
-  URL:=http://dast.nlanr.net/Projects/Iperf/
+  URL:=http://sourceforge.net/projects/iperf/
 endef
 
 define Package/iperf/Default/description
- Iperf is a modern alternative for measuring TCP and UDP bandwidth 
- performance, allowing the tuning of various parameters and 
+ Iperf is a modern alternative for measuring TCP and UDP bandwidth
+ performance, allowing the tuning of various parameters and
  characteristics.
 endef
 
-
 define Package/iperf
 $(call Package/iperf/Default)
   TITLE+= (with single thread support)
@@ -44,7 +43,6 @@ $(call Package/iperf/Default/description)
  This package is built with single thread support.
 endef
 
-
 define Package/iperf-mt
 $(call Package/iperf/Default)
   DEPENDS+= +libpthread
@@ -56,13 +54,12 @@ $(call Package/iperf/Default/description)
  This package is built with multithread support.
 endef
 
-
 define Build/Template
 
 $(STAMP_BUILT)-$(2): $(STAMP_PREPARED)
        -$(MAKE) -C $(PKG_BUILD_DIR) clean
        $(call Build/Configure/Default,$(3))
-       $(MAKE) -C $(PKG_BUILD_DIR)
+       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR)
        ( cd $(PKG_BUILD_DIR)/src; mv -f iperf iperf-$(2) )
        touch $$@
 
@@ -82,7 +79,6 @@ CONFIGURE_VARS += \
        CXX="g++-uc" \
        CXXFLAGS="$$$$CXX_CFLAGS -fno-rtti" \
 
-
 ifneq ($(SDK)$(CONFIG_PACKAGE_iperf),)
   define Build/singlethread
     $(call Build/Template,iperf,singlethread, \