[packages] quagga: Bump to v0.99.21
[openwrt/svn-archive/archive.git] / net / ipupdate / Makefile
index b48d2a210d81f36e2e0f86f294cd4fe2c0523724..7651a62af6acc4a9330dd30384ed20c7fd9750c0 100644 (file)
@@ -1,16 +1,15 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipupdate
 PKG_VERSION:=1.1.1
-PKG_RELEASE:=0
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ipupdate
@@ -22,6 +21,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/ipupdate
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=IP Addresses and Names
   TITLE:=IPUpdate-Daemon
   URL:=http://ipupdate.sourceforge.net
 endef
@@ -34,33 +34,37 @@ endef
 
 define Build/Configure
 $(call Build/Configure/Default,, \
-       UNAME_S="Linux" \
-       UNAME_R="$(LINUX_VERSION)" \
-       UNAME_M="$(ARCH)" \
+       UNAME_S="Linux" \
+       UNAME_R="$(LINUX_VERSION)" \
+       UNAME_M="$(ARCH)" \
 )
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)/usr
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               COPTS="$(TARGET_CFLAGS)" \
-               PRECOMPILED_FILTER=1 \
-               STAGING_DIR="$(STAGING_DIR)" \
-               DESTDIR="$(PKG_INSTALL_DIR)/usr" \
-               all
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)/usr
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+                $(TARGET_CONFIGURE_OPTS) \
+                CC="$(TARGET_CC) $(TARGET_CFLAGS) -s" \
+                PRECOMPILED_FILTER=1 \
+                STAGING_DIR="$(STAGING_DIR)" \
+                DESTDIR="$(PKG_INSTALL_DIR)/usr" \
+                all
 endef
 
 define Package/ipupdate/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ipupdate $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/ipupdate
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dollardns $(1)/etc/ipupdate/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/failover $(1)/etc/ipupdate/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ifip $(1)/etc/ipupdate/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/whatismyip $(1)/etc/ipupdate/
-       $(INSTALL_CONF) $(PKG_BUILD_DIR)/ipupdate.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ipupdate $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/ipupdate
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dollardns $(1)/etc/ipupdate/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/failover $(1)/etc/ipupdate/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ifip $(1)/etc/ipupdate/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/whatismyip $(1)/etc/ipupdate/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/ipupdate.conf $(1)/etc/
+endef
+
+define Package/ipupdate/conffiles
+/etc/ipupdate.conf
 endef
 
 $(eval $(call BuildPackage,ipupdate))