kamailio-5.x: bump to 5.1.3
[feed/telephony.git] / net / kamailio-5.x / Makefile
index f4481a73a9643613dff52e6b269b6349c25f03e0..ca8adc9409067b2d720145dd38088745e41a10a4 100644 (file)
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kamailio5
-PKG_VERSION:=5.1.1
-PKG_RELEASE:=3
+PKG_VERSION:=5.1.3
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=https://www.kamailio.org/pub/kamailio/$(PKG_VERSION)/src
 PKG_SOURCE:=kamailio-$(PKG_VERSION)$(PKG_VARIANT)_src.tar.gz
-PKG_HASH:=96f15fd639d6ea2f4f9921e83ecddff0ac42732f2709bcf7269d591952676fc4
+PKG_HASH:=b2266e15ec8ffa62be66b44989155f26a31d137f06f81fb3841aad8315315a14
 PKG_USE_MIPS16:=0
 
 PKG_LICENSE:=GPL-2.0+
 PKG_LICENSE_FILES:=COPYING
 PKG_MAINTAINER:=Jiri Slachta <jiri@slachta.eu>
 
+MODULES_AVAILABLE:= \
+       acc \
+       acc_diameter \
+       alias_db \
+       app_jsdt \
+       app_lua \
+       app_python \
+       app_sqlang \
+       async \
+       auth \
+       auth_db \
+       auth_diameter \
+       auth_ephemeral \
+       auth_identity \
+       auth_xkeys \
+       avp \
+       avpops \
+       benchmark \
+       blst \
+       call_control \
+       call_obj \
+       carrierroute \
+       cdp \
+       cdp_avp \
+       cfgutils \
+       cfg_db \
+       cfg_rpc \
+       cfgt \
+       cnxcc \
+       corex \
+       counters \
+       cplc \
+       crypto \
+       ctl \
+       db2_ldap \
+       db2_ops \
+       db_berkeley \
+       db_cluster \
+       db_flatstore \
+       db_mysql \
+       db_postgres \
+       db_sqlite \
+       db_text \
+       db_unixodbc \
+       debugger \
+       dialog \
+       dialplan \
+       dispatcher \
+       diversion \
+       dmq \
+       dmq_usrloc \
+       domain \
+       domainpolicy \
+       drouting \
+       enum \
+       erlang \
+       evapi \
+       evrexec \
+       exec \
+       group \
+       gzcompress \
+       h350 \
+       htable \
+       http_client \
+       imc \
+       ims_auth \
+       ims_charging \
+       ims_dialog \
+       ims_diameter_server \
+       ims_icscf \
+       ims_isc \
+       ims_ocs \
+       ims_qos \
+       ims_registrar_pcscf \
+       ims_registrar_scscf \
+       ims_usrloc_pcscf \
+       ims_usrloc_scscf \
+       ipops \
+       jansson \
+       janssonrpcc \
+       json \
+       jsonrpcs \
+       keepalive \
+       kex \
+       lcr \
+       ldap \
+       log_custom \
+       mangler \
+       matrix \
+       maxfwd \
+       mediaproxy \
+       mohqueue \
+       mqueue \
+       msilo \
+       msrp \
+       mtree \
+       nathelper \
+       nat_traversal \
+       ndb_redis \
+       nosip \
+       outbound \
+       p_usrloc \
+       path \
+       pdb \
+       pdt \
+       permissions \
+       pike \
+       pipelimit \
+       prefix_route \
+       presence \
+       presence_conference \
+       presence_dialoginfo \
+       presence_mwi \
+       presence_profile \
+       presence_reginfo \
+       presence_xml \
+       pua \
+       pua_bla \
+       pua_dialoginfo \
+       pua_reginfo \
+       pua_rpc \
+       pua_usrloc \
+       pua_xmpp \
+       pv \
+       qos \
+       ratelimit \
+       regex \
+       registrar \
+       rls \
+       rr \
+       rtimer \
+       rtjson \
+       rtpengine \
+       rtpproxy \
+       sanity \
+       sca \
+       sctp \
+       sdpops \
+       seas \
+       sipcapture \
+       sipdump \
+       sipt \
+       siptrace \
+       siputils \
+       sl \
+       sms \
+       smsops \
+       snmpstats \
+       speeddial \
+       sqlops \
+       ss7ops \
+       statistics \
+       statsc \
+       statsd \
+       stun \
+       sst \
+       tcpops \
+       textops \
+       textopsx \
+       timer \
+       tls \
+       tmrec \
+       topoh \
+       topos \
+       topos_redis \
+       tm \
+       tmx \
+       tsilo \
+       uac \
+       uac_redirect \
+       uid_auth_db \
+       uid_avp_db \
+       uid_domain \
+       uid_gflags \
+       uid_uri_db \
+       uri_db \
+       userblacklist \
+       usrloc \
+       utils \
+       uuid \
+       websocket \
+       xcap_client \
+       xcap_server \
+       xhttp \
+       xhttp_pi \
+       xhttp_rpc \
+       xlog \
+       xmlops \
+       xmlrpc \
+       xmpp \
+       xprint
+
+PKG_CONFIG_DEPENDS:= \
+       $(patsubst %,CONFIG_PACKAGE_$(PKG_NAME)-mod-%,$(subst _,-,$(MODULES_AVAILABLE)))
+
 include $(INCLUDE_DIR)/nls.mk
 include $(INCLUDE_DIR)/package.mk
 include $(TOPDIR)/feeds/packages/lang/python/python-host.mk
@@ -115,16 +310,15 @@ define Package/kamailio5-lib-libtrie/install
                                        $(1)/usr/lib/kamailio
 endef
 
-define Package/kamailio5-util-kambdb_recover
+define Package/kamailio5-util-kambdb-recover
 $(call Package/kamailio5/Default)
   TITLE:=Kamailio5 Berkeley DB recovery utility
-  DEPENDS:=kamailio5 +PACKAGE_kamailio5-util-kambdb_recover:kamailio5-mod-db-berkeley
+  DEPENDS:=kamailio5 +PACKAGE_kamailio5-util-kambdb-recover:kamailio5-mod-db-berkeley
 endef
 
-define Package/kamailio5-util-kambdb_recover/install
+define Package/kamailio5-util-kambdb-recover/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kambdb_recover \
-                               $(1)/usr/sbin/kambdb_recover
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kambdb_recover $(1)/usr/sbin
 endef
 
 define BuildKamailio5Module
@@ -204,7 +398,7 @@ endef
 $(eval $(call BuildPackage,kamailio5))
 $(eval $(call BuildPackage,kamailio5-lib-libkamailio-ims))
 $(eval $(call BuildPackage,kamailio5-lib-libtrie))
-$(eval $(call BuildPackage,kamailio5-util-kambdb_recover))
+$(eval $(call BuildPackage,kamailio5-util-kambdb-recover))
 
 ################################
 # Kamailio module parameters
@@ -256,7 +450,7 @@ $(eval $(call BuildKamailio5Module,db_berkeley,Berkeley DB backend,,+libdb47))
 $(eval $(call BuildKamailio5Module,db_cluster,Database clustering system,,))
 $(eval $(call BuildKamailio5Module,db_flatstore,fast write-only text DB-backend,,))
 $(eval $(call BuildKamailio5Module,db_mysql,MySQL DB-backend,,+libmysqlclient,mysql))
-$(eval $(call BuildKamailio5Module,db_postgres,PostgreSQL DB-backend,,@!arc +libpq,postgres))
+$(eval $(call BuildKamailio5Module,db_postgres,PostgreSQL DB-backend,,+libpq,postgres))
 $(eval $(call BuildKamailio5Module,db_sqlite,SQLite DB-backend,,+libsqlite3,db_sqlite))
 $(eval $(call BuildKamailio5Module,db_text,Text DB-backend,,,dbtext/kamailio))
 $(eval $(call BuildKamailio5Module,db_unixodbc,UnixODBC DB-backend,,+unixodbc))