Add asterisk prompts in German (#1463)
[openwrt/svn-archive/archive.git] / net / knock / Makefile
index d15cb53204b8e67ef2d889203d95400bafd2cb8b..0433e7b365cf6297b84572ebc011d589b522d163 100644 (file)
@@ -1,3 +1,9 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -5,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=knock
 PKG_VERSION:=0.5
 PKG_RELEASE:=1
-PKG_MD5SUM:=ca09d61458974cff90a700aba6120891
 
-PKG_SOURCE_URL:=http://www.zeroflux.org/knock/files/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.zeroflux.org/knock/files/
+PKG_MD5SUM:=ca09d61458974cff90a700aba6120891
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -16,96 +22,67 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/knock
+define Package/knock/Default
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libpcap
-  TITLE:=A port-knocking client
-  DESCRIPTION:=It listens to all traffic on an ethernet (or PPP) interface,\\\
-looking for special "knock" sequences of port-hits. A client\\\
-makes these port-hits by sending a TCP (or UDP) packet to a\\\
-port on the server. This port need not be open -- since\\\
-knockd listens at the link-layer level, it sees all traffic\\\
-even if it's destined for a closed port. When the server\\\
-detects a specific sequence of port-hits, it runs a command\\\
-defined in its configuration file. This can be used to open\\\
-up holes in a firewall for quick access.\\\
+  TITLE:=Port-knocking
+  DESCRIPTION:=\
+       It listens to all traffic on an ethernet (or PPP) interface, \\\
+       looking for special "knock" sequences of port-hits. A client \\\
+       makes these port-hits by sending a TCP (or UDP) packet to a \\\
+       port on the server. This port need not be open -- since \\\
+       knockd listens at the link-layer level, it sees all traffic \\\
+       even if it's destined for a closed port. When the server \\\
+       detects a specific sequence of port-hits, it runs a command \\\
+       defined in its configuration file. This can be used to open \\\
+       up holes in a firewall for quick access.
   URL:=http://www.zeroflux.org/cgi-bin/cvstrac/knock/wiki
 endef
 
+define Package/knock
+  $(call Package/knock/Default)
+  TITLE+= client
+  DESCRIPTION+=\\\
+       \\\
+       This package contains the port-knocking client.
+endef
+
 define Package/knockd
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+libpcap
-  TITLE:=A port-knocking server
-  DESCRIPTION:=It listens to all traffic on an ethernet (or PPP) interface,\\\
-looking for special "knock" sequences of port-hits. A client\\\
-makes these port-hits by sending a TCP (or UDP) packet to a\\\
-port on the server. This port need not be open -- since\\\
-knockd listens at the link-layer level, it sees all traffic\\\
-even if it's destined for a closed port. When the server\\\
-detects a specific sequence of port-hits, it runs a command\\\
-defined in its configuration file. This can be used to open\\\
-up holes in a firewall for quick access.\\\
-  URL:=http://www.zeroflux.org/cgi-bin/cvstrac/knock/wiki
+  $(call Package/knock/Default)
+  TITLE+= server
+  DESCRIPTION+=\\\
+       \\\
+       This package contains the port-knocking server.
 endef
 
 define Package/knockd/conffiles
 /etc/knockd.conf
 endef
 
-
 define Build/Configure
-        (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
-                $(TARGET_CONFIGURE_OPTS) \
-                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+       $(call Build/Configure/Default, \
+               , \
+               CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
                 ac_cv_lib_pcap_pcap_open_live=yes \
-                ./configure \
-                        --target=$(GNU_TARGET_NAME) \
-                        --host=$(GNU_TARGET_NAME) \
-                        --build=$(GNU_HOST_NAME) \
-                        --program-prefix="" \
-                        --program-suffix="" \
-                        --prefix=/usr \
-                        --exec-prefix=/usr \
-                        --bindir=/usr/bin \
-                        --datadir=/usr/share \
-                        --includedir=/usr/include \
-                        --infodir=/usr/share/info \
-                        --libdir=/usr/lib \
-                        --libexecdir=/usr/lib \
-                        --localstatedir=/var \
-                        --mandir=/usr/share/man \
-                        --sbindir=/usr/sbin \
-                        --sysconfdir=/etc/kismet \
-                        $(DISABLE_LARGEFILE) \
-                        $(DISABLE_NLS) \
-                        --enable-shared \
-                        --disable-static \
-                        --disable-rpath \
-                        --with-gnu-ld \
-        );
+        )
 endef
        
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CFLAGS="-I$(STAGING_DIR)/usr/include" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
        
 define Package/knock/install   
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/knock $(1)/usr/bin/
 endef
 
-define Package/kockd/install
-       install -d -m0755 $(1)/etc
-       install -m0600 $(PKG_INSTALL_DIR)/etc/knockd.conf $(1)/etc/
-       install -d -m0755 $(1)/usr/sbin
+define Package/knockd/install
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/knockd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/knockd $(1)/usr/sbin/
 endef