at: bump version
[feed/packages.git] / net / knot / Makefile
index d90341d46911e9292f4fb8236ab431afb35a138d..b537585d00b6b793f4f6c0473d443456366a278f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2014-2016 CZ.NIC, z.s.p.o. <knot-dns@labs.nic.cz>
+# Copyright (C) 2014-2017 CZ.NIC, z.s.p.o. <knot-dns@labs.nic.cz>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=knot
-PKG_VERSION:=2.2.1
+PKG_VERSION:=2.3.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-dns/
-PKG_MD5SUM:=d573ecadedf4f15ec1f02671443520cb
+PKG_HASH:=a929bce3b957a81776b1db7b43b0e4473339bf16be8dbba5abb4b0593bf43c94
 
 PKG_MAINTAINER:=Daniel Salzman <daniel.salzman@nic.cz>
 PKG_LICENSE:=GPL-3.0 LGPL-2.0 0BSD MIT OLDAP-2.8
@@ -88,16 +88,22 @@ define Package/knot-nsec3hash
        DEPENDS=+knot-libdnssec
 endef
 
+define Package/knot-zonecheck
+       $(call Package/knot/Default)
+       TITLE+= zonefile check utility
+       DEPENDS=+liburcu +knot-libdnssec +knot-libknot +knot-libzscanner
+endef
+
 define Package/knot-keymgr
        $(call Package/knot/Default)
        TITLE+= DNSSEC key management utility
-       DEPENDS=+knot-libdnssec +knot-libzscanner
+       DEPENDS=+liburcu +knot-libdnssec +knot-libknot +knot-libzscanner
 endef
 
 define Package/knot-tests
        $(call Package/knot/Default)
        TITLE+= tests
-       DEPENDS=+liburcu +knot-libdnssec +knot-libknot +knot-libzscanner
+       DEPENDS=+liburcu +libedit +knot-libdnssec +knot-libknot +knot-libzscanner
 endef
 
 define Package/knot-libdnssec/description
@@ -132,6 +138,10 @@ define Package/knot-nsec3hash/description
        Knot DNS simple NSEC3 hash utility.
 endef
 
+define Package/knot-zonecheck/description
+       Knot DNS zonefile check utility.
+endef
+
 define Package/knot-keymgr/description
        Knot DNS DNSSEC key management utility.
 endef
@@ -172,6 +182,12 @@ define Build/InstallDev
        $(INSTALL_DIR)                                          $(1)/usr/include/libknot
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libknot/*          $(1)/usr/include/libknot/
 
+       $(INSTALL_DIR)                                          $(1)/usr/include/dnssec
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/dnssec/*           $(1)/usr/include/dnssec/
+
+       $(INSTALL_DIR)                                          $(1)/usr/include/zscanner
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/zscanner/*         $(1)/usr/include/zscanner/
+
        $(INSTALL_DIR)                                                  $(1)/usr/lib/pkgconfig
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc       $(1)/usr/lib/pkgconfig/
 endef
@@ -192,8 +208,9 @@ define Package/knot-libzscanner/install
 endef
 
 define Package/knot/install
+       $(INSTALL_DIR)                                          $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/knotc        $(1)/usr/bin/
        $(INSTALL_DIR)                                          $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/knotc        $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/knotd        $(1)/usr/sbin/
 
        $(INSTALL_DIR)                                                  $(1)/etc/knot
@@ -223,9 +240,14 @@ define Package/knot-nsec3hash/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/knsec3hash    $(1)/usr/bin/
 endef
 
+define Package/knot-zonecheck/install
+       $(INSTALL_DIR)                                          $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/kzonecheck    $(1)/usr/bin/
+endef
+
 define Package/knot-keymgr/install
-       $(INSTALL_DIR)                                          $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/keymgr       $(1)/usr/sbin/
+       $(INSTALL_DIR)                                          $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/keymgr       $(1)/usr/bin/
 endef
 
 define Package/knot-tests/install
@@ -237,18 +259,34 @@ define Package/knot-tests/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/libtap/tap/libtap.sh    $(1)/usr/share/knot/tap/
 
        $(INSTALL_DIR)                                                                  $(1)/usr/share/knot/tests
+       find $(PKG_BUILD_DIR)/tests/.libs -maxdepth 1 -executable -type f | \
+               xargs -I{} basename {} | \
+               xargs -I{} $(INSTALL_BIN) -T $(PKG_BUILD_DIR)/tests/.libs/{}            $(1)/usr/share/knot/tests/test_{}
 
+       $(INSTALL_DIR)                                                                  $(1)/usr/share/knot/tests/dnssec
        find $(PKG_BUILD_DIR)/src/dnssec/tests -maxdepth 1 -executable -type f | \
                xargs -I{} basename {} | \
-               xargs -I{} $(INSTALL_BIN) -T $(PKG_BUILD_DIR)/src/dnssec/tests/{}       $(1)/usr/share/knot/tests/dnssec_test_{}
+               xargs -I{} $(INSTALL_BIN) -T $(PKG_BUILD_DIR)/src/dnssec/tests/{}       $(1)/usr/share/knot/tests/dnssec/test_{}
 
-       find $(PKG_BUILD_DIR)/tests/.libs -maxdepth 1 -executable -type f | \
+       $(INSTALL_DIR)                                                                  $(1)/usr/share/knot/tests/contrib
+       find $(PKG_BUILD_DIR)/tests/contrib/.libs -maxdepth 1 -executable -type f | \
                xargs -I{} basename {} | \
-               xargs -I{} $(INSTALL_BIN) -T $(PKG_BUILD_DIR)/tests/.libs/{}            $(1)/usr/share/knot/tests/test_{}
+               xargs -I{} $(INSTALL_BIN) -T $(PKG_BUILD_DIR)/tests/contrib/.libs/{}    $(1)/usr/share/knot/tests/contrib/{}
+
+       $(INSTALL_DIR)                                                                  $(1)/usr/share/knot/tests/libknot
+       find $(PKG_BUILD_DIR)/tests/libknot/.libs -maxdepth 1 -executable -type f | \
+               xargs -I{} basename {} | \
+               xargs -I{} $(INSTALL_BIN) -T $(PKG_BUILD_DIR)/tests/libknot/.libs/{}    $(1)/usr/share/knot/tests/libknot/{}
 
+       $(INSTALL_DIR)                                                                  $(1)/usr/share/knot/tests/modules
        find $(PKG_BUILD_DIR)/tests/modules/.libs -maxdepth 1 -executable -type f | \
                xargs -I{} basename {} | \
-               xargs -I{} $(INSTALL_BIN) -T $(PKG_BUILD_DIR)/tests/modules/.libs/{}    $(1)/usr/share/knot/tests/test_module_{}
+               xargs -I{} $(INSTALL_BIN) -T $(PKG_BUILD_DIR)/tests/modules/.libs/{}    $(1)/usr/share/knot/tests/modules/test_{}
+
+       $(INSTALL_DIR)                                                                  $(1)/usr/share/knot/tests/utils
+       find $(PKG_BUILD_DIR)/tests/utils/.libs -maxdepth 1 -executable -type f | \
+               xargs -I{} basename {} | \
+               xargs -I{} $(INSTALL_BIN) -T $(PKG_BUILD_DIR)/tests/utils/.libs/{}      $(1)/usr/share/knot/tests/utils/{}
 
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/zscanner/tests/.libs/zscanner-tool  $(1)/usr/share/knot/tests/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/zscanner/tests/unittests            $(1)/usr/share/knot/tests/test_zscanner
@@ -264,5 +302,6 @@ $(eval $(call BuildPackage,knot-dig))
 $(eval $(call BuildPackage,knot-host))
 $(eval $(call BuildPackage,knot-nsupdate))
 $(eval $(call BuildPackage,knot-nsec3hash))
+$(eval $(call BuildPackage,knot-zonecheck))
 $(eval $(call BuildPackage,knot-keymgr))
 $(eval $(call BuildPackage,knot-tests))