packages/scpa5xx-view: use lowercase config option, use new service functions
[openwrt/svn-archive/archive.git] / net / lftp / Makefile
index ea4f95dcb98c8930cccd4adc00b92e7c3167ed08..5a562119858a34e681dc6dc730ccc34c2d5c8212 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,20 +8,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lftp
-PKG_VERSION:=4.0.7
+PKG_VERSION:=4.3.1
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://lftp.cybermirror.org \
   http://lftp.cybermirror.org/old
-PKG_MD5SUM:=a40e4518fc477c82ffcc5b04d9ff64ff
+PKG_MD5SUM:=ccef0f84416fc964b7b8a5e3f2e87631
 
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lftp
-  SUBMENU:=FTP
+  SUBMENU:=File Transfer
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libncurses +libopenssl +libreadline +uclibcxx +libexpat
@@ -32,11 +32,10 @@ endef
 define Package/lftp/description
   lftp is sophisticated file transfer program with command line interface. It
   supports FTP, HTTP, FISH, SFTP and FILE (local FS) protocols. GNU Readline
-  library is used for input.
+  library is used for input. BitTorrent protocol is supported as built-in
+  `torrent' command.
 endef
 
-# uses GNU configure
-
 CONFIGURE_ARGS += \
        --without-libiconv-prefix \
        --without-libintl-prefix \
@@ -46,37 +45,19 @@ CONFIGURE_ARGS += \
        --disable-static
 
 CONFIGURE_VARS += \
-        CXXFLAGS="$$$$CXXFLAGS -fno-builtin -I$(STAGING_DIR)/usr/include/uClibc++ -nostdinc++" \
-        CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
-        LDFLAGS="$$$$LDFLAGS" \
-        LIBS="-nodefaultlibs -lz -lutil -luClibc++ -lcurses -lgcc $(LIBGCC_S) -ldl" \
+       CXX="$(STAGING_DIR)/host/bin/g++-uc" \
+       CXXFLAGS="$$$$CXXFLAGS -fno-builtin -I$(STAGING_DIR)/usr/include/uClibc++ -nostdinc++" \
+       CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
+       LDFLAGS="$$$$LDFLAGS" \
+       LIBS="-nodefaultlibs -lz -lutil -lc -luClibc++ -lcurses $(LIBGCC_S) -ldl" \
+       i_cv_posix_fallocate_works=no
 
 MAKE_VARS += \
-       LD="\$$$$(CC)" \
+       LD="\$$$$(CC)"
 
 define Package/lftp/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_DIR) $(1)/usr/lib
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lftp $(1)/usr/bin/
 endef
 
-define Package/lftp/postinst
-# check for real system
-if [ -z "$${IPKG_INSTROOT}" ]; then
-       if [ ! -e $${IPKG_INSTROOT}/usr/lib/libstdc\+\+.so.6 ]; then
-               ln -s $${IPKG_INSTROOT}/usr/lib/libuClibc++.so.0 $${IPKG_INSTROOT}/usr/lib/libstdc\+\+.so.6
-       fi
-fi
-
-endef
-
-define Package/lftp/postrm
-if [ -z "$${IPKG_INSTROOT}" ]; then
-        if [ -L $${IPKG_INSTROOT}/usr/lib/libstdc\+\+.so.6 ]; then
-               rm $${IPKG_INSTROOT}/usr/lib/libstdc\+\+.so.6
-       fi
-fi
-
-endef
-
 $(eval $(call BuildPackage,lftp))