[package] start nmbd, bump release number (#6448)
[openwrt/svn-archive/archive.git] / net / miax / Makefile
index cbaa9b9b79ceee37c975cc7356d0722adbf6dba1..f7b7f2396100d978793dd3180c041e6dea5dc5f2 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -13,9 +12,8 @@ PKG_VERSION:=1.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://mesh.dl.sourceforge.net/sourceforge/miax/
+PKG_SOURCE_URL:=@SF/miax
 PKG_MD5SUM:=44f0d2ef46ee2697d890b7b96846adc7
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
@@ -26,25 +24,27 @@ define Package/miax
   CATEGORY:=Network
   DEPENDS:=+libpthread +bluez-libs
   TITLE:=A console iax (asterisk) client
-  DESCRIPTION:=\
-       miax is a console iax (asterisk) client, it can work with \\\
-       a soundcard as a normal voip phone, taking input/output from \\\
+  URL:=http://www.eja.it/?l=en&n=miax
+endef
+
+define Package/miax/description
+       miax is a console iax (asterisk) client, it can work with 
+       a soundcard as a normal voip phone, taking input/output from 
        keyboard, analog/gsm/isdn modem or bluetooth phones.
-  URL:=http://www.eja.it/?l=gpl&testo=miax
 endef
 
 define Build/Compile
        $(MAKE) -C "$(PKG_BUILD_DIR)" \
                CC="$(TARGET_CC)" \
                OFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                all
 endef
 
 define Package/miax/install    
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/miax $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/miax $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,miax))