[package] fix miniupnpd compilation with iptables-1.4.3.2 (#5047)
[openwrt/svn-archive/archive.git] / net / miniupnpd / Makefile
index 9866674003bdc85c7193c03dee48cd6d7450c737..a479b78b0db5e3f45aec7da2b12b49672ae33270 100644 (file)
@@ -1,15 +1,16 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=miniupnpd
 PKG_VERSION:=1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=b5e70e80dcf45b424b8fe3c966bdc613
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
@@ -30,7 +31,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.openwrt \
                $(TARGET_CONFIGURE_OPTS) \
                STAGING_DIR="$(STAGING_DIR)" \
-               CFLAGS="$(TARGET_CFLAGS) -I $(STAGING_DIR)/usr/include -DIPTABLES_143" \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(KERNEL_BUILD_DIR)/iptables-1.4.3.2/include -DIPTABLES_143" \
                LIBS="$(STAGING_DIR)/usr/lib/libiptc.so"
 endef