[packages] pure-ftpd: update to 1.0.28
[openwrt/svn-archive/archive.git] / net / mtr / Makefile
index 4237b4f8d8202ab942f61c23ad7e660f53171cdc..4505b6068bdd7456c00e84f583d088de73c02636 100644 (file)
@@ -4,21 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtr
-PKG_VERSION:=0.69
+PKG_VERSION:=0.75
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr/
-PKG_MD5SUM:=58904d6d8d70114195cdeb653d56914c
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=23baca52d0922c2ecba7eba05317868c
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,13 +26,13 @@ define Package/mtr
 endef
 
 define Package/mtr/description
-       mtr combines the functionality of the 'traceroute' and 'ping' programs 
+       mtr combines the functionality of the 'traceroute' and 'ping' programs
        in a single network diagnostic tool.
-       As mtr starts, it investigates the network connection between the host 
-       mtr runs on and a user-specified destination host. After it 
-       determines the address of each network hop between the machines, 
-       it sends a sequence ICMP ECHO requests to each one to determine the 
-       quality of the link to each machine. As it does this, it prints 
+       As mtr starts, it investigates the network connection between the host
+       mtr runs on and a user-specified destination host. After it
+       determines the address of each network hop between the machines,
+       it sends a sequence ICMP ECHO requests to each one to determine the
+       quality of the link to each machine. As it does this, it prints
        running statistics about each machine.
 endef
 
@@ -58,15 +53,15 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/mtr/install     
+define Package/mtr/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mtr $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mtr $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,mtr))