Update libmpcdec to 1.2.6 (#3601)
[openwrt/svn-archive/archive.git] / net / mtr / Makefile
index 47944a060167cd81fe7b025670186677d89d699a..874947d81c09edbbd62eefcfdca87ad02fff616f 100644 (file)
@@ -9,16 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtr
-PKG_VERSION:=0.69
+PKG_VERSION:=0.73
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr/
-PKG_MD5SUM:=58904d6d8d70114195cdeb653d56914c
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=52223cc34c72092a0392865356a3dc76
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,19 +23,30 @@ define Package/mtr
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=Full screen ncurses traceroute tool
-  DESCRIPTION:=\
-       mtr combines the functionality of the 'traceroute' and 'ping' programs \\\
-       in a single network diagnostic tool.\\\
-       As mtr starts, it investigates the network connection between the host \\\
-       mtr runs on and a user-specified destination host.  After it \\\
-       determines the address of each network hop between the machines, \\\
-       it sends a sequence ICMP ECHO requests to each one to determine the \\\
-       quality of the link to each machine.  As it does this, it prints \\\
-       running statistics about each machine.
   URL:=http://www.bitwizard.nl/mtr/
 endef
 
+define Package/mtr/description
+       mtr combines the functionality of the 'traceroute' and 'ping' programs
+       in a single network diagnostic tool.
+       As mtr starts, it investigates the network connection between the host
+       mtr runs on and a user-specified destination host. After it
+       determines the address of each network hop between the machines,
+       it sends a sequence ICMP ECHO requests to each one to determine the
+       quality of the link to each machine. As it does this, it prints
+       running statistics about each machine.
+endef
+
 define Build/Configure
+       (cd $(PKG_BUILD_DIR); touch \
+               configure.in \
+               aclocal.m4 \
+               Makefile.in \
+               img/Makefile.in \
+               stamp-h.in \
+               config.h.in \
+               configure \
+       );
        $(call Build/Configure/Default, \
                --without-gtk \
                , \
@@ -54,8 +61,8 @@ define Build/Compile
 endef
 
 define Package/mtr/install     
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mtr $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mtr $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,mtr))