[packages] fix samba3 logging in nmbd when CONFIG_SAMBA3_DEBUG is enabled (#6389)
[openwrt/svn-archive/archive.git] / net / nbd / Makefile
index 77ffa2926b3fce98ca9dad175739be909aed3c32..46928289d1a119c63e3dc946316bb40aad516fd0 100644 (file)
@@ -1,20 +1,19 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $ 
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nbd
-PKG_VERSION:=2.9.11
+PKG_VERSION:=2.9.13
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nbd
-PKG_MD5SUM:=7fdd912edba85b82f599e17449ccea40
+PKG_MD5SUM:=6c83f0f5bfd87ea60f10223843bd9679
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,21 +31,17 @@ define Package/nbd/description
   This package contains the network block device client.
 endef
 
-CONFIGURE_ARGS += \
+CONFIGURE_ARGS+= \
        --disable-glibtest
-CONFIGURE_VARS += GLIB_CFLAGS="-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include"
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS) -L$(STAGING_DIR)/usr/lib/libintl/lib/ -L$(STAGING_DIR)/usr/lib/" \
                nbd-client
 endef
 
 define Package/nbd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/nbd-client $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/nbd-client $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,nbd))