[curl]: upgrade to 7.33.0, add myself as maintainer
[openwrt/svn-archive/archive.git] / net / netcat / Makefile
index c5bd1fe31fba573676150fb123858d50940a6df9..b2e95ca84a99cc55f69dd6bcebcb6fd27ed51433 100644 (file)
@@ -2,15 +2,13 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netcat
 PKG_VERSION:=0.7.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 PKG_MD5SUM:=0a29eff1736ddb5effd0b1ec1f6fe0ef
-PKG_CAT:=bzcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -18,12 +16,14 @@ define Package/netcat
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A feature-rich network debugging and exploration tool.
-  DESCRIPTION:=\
-               Netcat is a featured networking utility which reads and writes data across network connections, using the TCP/IP protocol. \\\
-It is designed to be a reliable "back-end" tool that can be used directly or easily driven by other programs and scripts. At the same time, it is a feature-rich network debugging and exploration tool, since it can create almost any kind of connection you would need and has several interesting built-in capabilities.
   URL:=http://netcat.sourceforge.net/
 endef
 
+define Package/netcat/description
+               Netcat is a featured networking utility which reads and writes data across network connections, using the TCP/IP protocol. 
+       It is designed to be a reliable "back-end" tool that can be used directly or easily driven by other programs and scripts. At the same time, it is a feature-rich network debugging and exploration tool, since it can create almost any kind of connection you would need and has several interesting built-in capabilities.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --disable-rpath \
@@ -31,12 +31,6 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-       all install
-endef
-
 define Package/netcat/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/netcat \