[packages] olsrd: Backport fixes to quagga plugin
[openwrt/svn-archive/archive.git] / net / netstat-nat / Makefile
index 716796f49d8f99c4c9672608d0934723c7ee0353..190950fe06932da28dfac0e82d4a948be453e637 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,10 +14,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://tweegy.demon.nl/download/
 PKG_MD5SUM:=ccf71a6cbd9a513ea3adec54b54ee770
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,15 +21,17 @@ define Package/netstat-nat
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A netstat variant for NAT connections
-  DESCRIPTION:=\
-       Netstat-nat is a small program written in C.\\\
-       It displays NAT connections, managed by netfilter/iptables which comes \\\
-       with the > 2.4.x linux kernels.\\\
-       The program reads its information from '/proc/net/ip_conntrack', which \\\
-       is the temporary conntrack-storage of netfilter.
   URL:=http://tweegy.demon.nl/projects/netstat-nat/
 endef
 
+define Package/netstat-nat/description
+       Netstat-nat is a small program written in C.
+       It displays NAT connections, managed by netfilter/iptables which comes 
+       with the > 2.4.x linux kernels.
+       The program reads its information from '/proc/net/ip_conntrack', which 
+       is the temporary conntrack-storage of netfilter.
+endef
+
 # uses GNU configure
 
 define Build/Compile   
@@ -44,8 +41,8 @@ define Build/Compile
 endef
 
 define Package/netstat-nat/install     
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/netstat-nat $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/netstat-nat $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,netstat-nat))