This patch updates uanytun package to new upstream release 0.3.3.
[openwrt/svn-archive/archive.git] / net / ngrep / Makefile
index 924a1e97787df5b4a875f9854e776e7e39a2271d..5321f0412907ee603283266f7223dffb7d5666fd 100644 (file)
@@ -1,24 +1,19 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ngrep
 PKG_VERSION:=1.45
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/ngrep
 PKG_MD5SUM:=bc8150331601f3b869549c94866b4f1c
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -44,10 +39,9 @@ define Build/Configure
                --with-pcap-includes=$(STAGING_DIR)/usr/include \
                --enable-pcre \
                --with-pcre=$(STAGING_DIR)/usr \
-               --enable-ipv6 \
                --disable-dropprivs \
                ,\
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -lpcre" \
+               LDFLAGS="$(TARGET_LDFLAGS) -lpcre" \
        )
 endef