[packages] coova-chilli: update to v1.2.0 (#6501)
[openwrt/svn-archive/archive.git] / net / ntpd / Makefile
index 910d12f5d8f820b6dff2279b9c4c988a50b6921d..2ce27568e64bdcc943d0c2b48e718abe96e23352 100644 (file)
@@ -1,22 +1,20 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntp
-PKG_VERSION:=4.2.4p4
-PKG_RELEASE:=3
+PKG_VERSION:=4.2.6
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/
-PKG_MD5SUM:=fcb32a01e1ae3f9ed5bac86b12c7a1cc
+PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/
+PKG_MD5SUM:=4d64a99592b818aa9419fc9dcb149746
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_DEPENDS:=libelf
 
 include $(INCLUDE_DIR)/package.mk
@@ -57,7 +55,7 @@ endef
 
 define Package/ntp-utils
   $(call Package/ntpd/Default)
-  DEPENDS:=+libreadline +libncurses
+  DEPENDS:=+libncurses
   TITLE+= utilities
 endef
 
@@ -92,6 +90,9 @@ endef
 
 TARGET_CPPFLAGS += -I$(STAGING_DIR)/usr/include/libelf
 
+CONFIGURE_VARS += \
+       ac_cv_header_md5_h=no
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --disable-all-clocks \
@@ -99,7 +100,9 @@ define Build/Configure
                --enable-NMEA \
                --enable-LOCAL-CLOCK \
                --enable-SHM \
-               --enable-linuxcaps \
+               --disable-linuxcaps, \
+               ac_cv_lib_rt_sched_setscheduler=no \
+               ac_cv_header_dns_sd_h=no \
        )
 endef
 
@@ -112,7 +115,7 @@ define Package/ntpd/install
        $(INSTALL_DIR) $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpd/ntpd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) ./files/ntp.conf $(1)/etc/
+       $(INSTALL_CONF) ./files/ntp.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/ntpd.init $(1)/etc/init.d/ntpd
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
@@ -122,6 +125,8 @@ endef
 define Package/ntpdate/install
        $(INSTALL_DIR) $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpdate/ntpdate $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/ntpdate.init $(1)/etc/init.d/ntpdate
 endef
 
 define Package/ntp-utils/install