[packages] dante: fix compilation with backfire
[openwrt/svn-archive/archive.git] / net / opendchub / Makefile
index cc4a3f3a2d9b49740cc2a935756184bb0c46fce0..a6ef84eda4b747aa620ab835f5347f71fca671b5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opendchub
-PKG_VERSION:=0.7.15
+PKG_VERSION:=0.8.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/opendchub
-PKG_MD5SUM:=8f9ab5bb7f85730f4b1ce7cceb6aef96
+PKG_MD5SUM:=e812ac26323f3a8113ce1a0761ce9544
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,7 +25,7 @@ define Package/opendchub
   CATEGORY:=Network
   DEPENDS:=+libopenssl +libpthread
   TITLE:=software for the Direct Connect network
-  URL:=http://opendchub.sourceforge.net
+  URL:=http://opendchub.sourceforge.net/
 endef
 
 define Package/opendchub/description
@@ -31,20 +33,10 @@ define Package/opendchub/description
        for the Direct Connect network
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default,\
-               --disable-perl \
-       )
-endef
-
-define Build/Compile   
-       $(call Build/Compile/Default,\
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install \
-       )
-endef
+CONFIGURE_ARGS += \
+       --disable-perl \
 
-define Package/opendchub/install       
+define Package/opendchub/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opendchub $(1)/usr/bin/
 endef