petitboot: Update to current repository revision
[openwrt/svn-archive/archive.git] / net / openssh / Makefile
index 2c1853719f01ddac98a82f9f2e62904007c46334..f8d621b275fb2081dd966b72f1e26ee54e8b4ff8 100644 (file)
@@ -1,27 +1,22 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
-PKG_VERSION:=4.7p1
+PKG_VERSION:=5.2p1
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
                ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
-               ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
-               ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
-PKG_MD5SUM:=50a800fd2c6def9e9a53068837e87b91
-PKG_CAT:=zcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+               ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
+               ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
+PKG_MD5SUM:=ada79c7328a8551bdf55c95e631e7dad
 
 PKG_BUILD_DEPENDS:=libopenssl
 
@@ -32,8 +27,12 @@ define Package/openssh-client
   CATEGORY:=Network
   DEPENDS:=+libopenssl +zlib
   TITLE:=OpenSSH client
-  DESCRIPTION:=OpenSSH client.
   URL:=http://www.openssh.com/
+  SUBMENU:=SSH
+endef
+
+define Package/openssh-client/description
+OpenSSH client.
 endef
 
 define Package/openssh-client/conffiles
@@ -45,8 +44,12 @@ define Package/openssh-client-utils
   CATEGORY:=Network
   DEPENDS:=openssh-client
   TITLE:=OpenSSH client utilities
-  DESCRIPTION:=OpenSSH client utilities.
   URL:=http://www.openssh.com/
+  SUBMENU:=SSH
+endef
+
+define Package/openssh-client-utils/description
+OpenSSH client utilities.
 endef
 
 define Package/openssh-server
@@ -54,8 +57,12 @@ define Package/openssh-server
   CATEGORY:=Network
   DEPENDS:=+libopenssl +zlib
   TITLE:=OpenSSH server
-  DESCRIPTION:=OpenSSH server.
   URL:=http://www.openssh.com/
+  SUBMENU:=SSH
+endef
+
+define Package/openssh-server/description
+OpenSSH server.
 endef
 
 define Package/openssh-server/conffiles
@@ -67,8 +74,12 @@ define Package/openssh-sftp-client
   CATEGORY:=Network
   DEPENDS:=+libopenssl +zlib
   TITLE:=OpenSSH SFTP client
-  DESCRIPTION:=OpenSSH SFTP client.
   URL:=http://www.openssh.com/
+  SUBMENU:=SSH
+endef
+
+define Package/openssh-sftp-client/description
+OpenSSH SFTP client.
 endef
 
 define Package/openssh-sftp-server
@@ -76,54 +87,40 @@ define Package/openssh-sftp-server
   CATEGORY:=Network
   DEPENDS:=
   TITLE:=OpenSSH SFTP server
-  DESCRIPTION:=OpenSSH SFTP server.
   URL:=http://www.openssh.com/
+  SUBMENU:=SSH
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LD="$(TARGET_CC)" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc/ssh \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --disable-static \
-                       --disable-debug \
-                       --disable-strip \
-                       --disable-etc-default-login \
-                       --disable-lastlog \
-                       --disable-utmp \
-                       --disable-utmpx \
-                       --disable-wtmp \
-                       --disable-wtmpx \
-                       --without-bsd-auth \
-                       --without-kerberos5 \
-                       --without-pam \
-                       --without-x \
-       );
+define Package/openssh-sftp-server/description
+OpenSSH SFTP server.
 endef
 
+CONFIGURE_ARGS+= \
+       $(DISABLE_LARGEFILE) \
+       $(DISABLE_NLS) \
+       --sysconfdir=/etc/ssh \
+       --enable-shared \
+       --disable-static \
+       --disable-debug \
+       --disable-strip \
+       --disable-etc-default-login \
+       --disable-lastlog \
+       --disable-utmp \
+       --disable-utmpx \
+       --disable-wtmp \
+       --disable-wtmpx \
+       --without-bsd-auth \
+       --without-kerberos5 \
+       --without-pam \
+       --without-x
+
+ifneq ($(CONFIG_SSP_SUPPORT),y)
+CONFIGURE_ARGS += \
+       --without-stackprotect
+endif
+
+CONFIGURE_VARS += LD="$(TARGET_CC)"
+
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
@@ -133,6 +130,7 @@ define Build/Compile
                sftp-server
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               STRIP_OPT="" \
                all install
 endef
 
@@ -141,15 +139,13 @@ define Package/openssh-client/install
        chmod 0700 $(1)/etc/ssh
        $(CP) $(PKG_INSTALL_DIR)/etc/ssh/ssh_config $(1)/etc/ssh/
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ssh $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/scp $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ssh $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/scp $(1)/usr/bin/
 endef
 
 define Package/openssh-client-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ssh-add $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ssh-agent $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ssh-keyscan $(1)/usr/bin/
+       $(INSTALL_BIN) $(foreach bin,add agent keyscan keysign,$(PKG_BUILD_DIR)/ssh-$(bin)) $(1)/usr/bin/
 endef
 
 define Package/openssh-server/install
@@ -159,9 +155,9 @@ define Package/openssh-server/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/sshd.init $(1)/etc/init.d/sshd
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ssh-keygen $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ssh-keygen $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/sshd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/sshd $(1)/usr/sbin/
 endef
 
 define Package/openssh-server/postinst
@@ -206,7 +202,7 @@ endef
 
 define Package/openssh-sftp-client/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/sftp $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sftp $(1)/usr/bin/
 endef
 
 define Package/openssh-sftp-server/install