Merge pull request #4949 from commodo/python-lxml-update
[feed/packages.git] / net / openvswitch / Makefile
index 9ed3a3f0238c60cdf2ea678a447ff45f93fe2055..ddd5802dbffe06ce755de45274332bb1c7f60ed7 100644 (file)
@@ -12,18 +12,18 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=openvswitch
 
-PKG_RELEASE:=2
-PKG_VERSION:=2.7.0
-PKG_RELEASE=$(PKG_SOURCE_VERSION)
+PKG_RELEASE:=1
+PKG_VERSION:=2.7.2
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=COPYING
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://openvswitch.org/releases/
-PKG_HASH:=e492cf08a929b4a2178b7f9b01dc4ff562f44138b547b4e942078187b2445d2e
+PKG_HASH:=fe36c86ed52f6f7c17b01cdbb7ae37bf521cc5c2e50997b618f3f742485f655b
 
-PKG_BUILD_DEPENDS:=python-six/host
+PKG_BUILD_DEPENDS:=python/host python-six/host
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_openvswitch-python
 
 PKG_BUILD_PARALLEL:=1
 PKG_FIXUP:=autoreconf
@@ -67,7 +67,7 @@ endef
 define Package/openvswitch-python
   $(call Package/openvswitch/Default)
   TITLE:=Open vSwitch Python Support
-  DEPENDS:=+openvswitch +python +python-six
+  DEPENDS:=+openvswitch +PACKAGE_openvswitch-python:python +PACKAGE_openvswitch-python:python-six
 endef
 
 define Package/openvswitch-python/description
@@ -118,7 +118,10 @@ CONFIGURE_ARGS += --enable-shared
 TARGET_CFLAGS += -flto -std=gnu99
 
 CONFIGURE_VARS += KARCH=$(LINUX_KARCH)
-MAKE_FLAGS += ARCH="$(LINUX_KARCH)"
+MAKE_FLAGS += \
+       ARCH="$(LINUX_KARCH)" \
+       PYTHONPATH="$(HOST_PYTHONPATH)" \
+       PYTHON="$(HOST_PYTHON_BIN)"
 
 define OvsBinUtility
   define Package/openvswitch-$(1)