treewide: refresh hashes after move to use ZSTD as default
[feed/telephony.git] / net / pcapsipdump / Makefile
index ad077469548124941ff932e492293753efb9b796..8770da1730af558a08f96d318e25213607e133c3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,39 +8,36 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pcapsipdump
-PKG_VERSION:=0.1.4
-PKG_RELEASE:=3
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/psipdump
-PKG_MD5SUM:=95ed26caf66237a654cae2cacdaa3386
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_URL:=https://svn.code.sf.net/p/pcapsipdump/code/trunk
+PKG_MIRROR_HASH:=563050f47c7962de377cab17478a86d3ea6726a331a7c77be62cb3f5488e519a
+PKG_SOURCE_VERSION:=157
+PKG_SOURCE_DATE=2020-03-03
+PKG_RELEASE:=1
+
+PKG_LICENSE:=GPL-2.0+
+PKG_LICENSE_FILES:=LICENSE
 
-include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pcapsipdump
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Telephony
-  DEPENDS:=+libpcap $(CXX_DEPENDS)
-  TITLE:=SIP sessions dumping tool
+  DEPENDS:=+libstdcpp +USE_GLIBC:libbsd +libpcap
+  TITLE:=SIP Sessions Dumping Tool
   URL:=http://sourceforge.net/projects/pcapsipdump/
 endef
 
 define Package/pcapsipdump/description
-        pcapsipdump is a tool for dumping SIP sessions (+RTP traffic, if available) to disk in a
-        fashion similar to "tcpdump -w" (format is exactly the same), but one file per sip session
-        (even if there is thousands of concurrect SIP sessions).
+ pcapsipdump is a tool for dumping SIP sessions (plus RTP traffic, if
+ available) to disk in a fashion similar to "tcpdump -w" (format is
+ exactly the same), but one file per SIP session (even if there are
+ thousands of concurrent SIP sessions).
 endef
 
-TARGET_CC=$(TARGET_CXX)
-
-define Build/Compile
-       $(TARGET_CONFIGURE_OPTS) \
-               $(MAKE) -C $(PKG_BUILD_DIR) \
-               CPPFLAGS="$(TARGET_CXXFLAGS) -fno-rtti"  \
-               LIBS="-lpcap"
-endef
+MAKE_FLAGS+=LIBS="-lpcap"
 
 define Package/pcapsipdump/install
        $(INSTALL_DIR) $(1)/usr/bin