treewide: refresh hashes after move to use ZSTD as default
[feed/telephony.git] / net / pcapsipdump / Makefile
index ebc3a9bd54d0ed9bbef06f65acc1debc1fb4a6ef..8770da1730af558a08f96d318e25213607e133c3 100644 (file)
@@ -8,38 +8,36 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pcapsipdump
-PKG_VERSION:=0.2
-PKG_RELEASE:=3
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/pcapsipdump
-PKG_HASH:=4d4dc2664963c08de40da47ca0dcd1eeae09edc42241bd6daa7ff8c59089dce9
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_URL:=https://svn.code.sf.net/p/pcapsipdump/code/trunk
+PKG_MIRROR_HASH:=563050f47c7962de377cab17478a86d3ea6726a331a7c77be62cb3f5488e519a
+PKG_SOURCE_VERSION:=157
+PKG_SOURCE_DATE=2020-03-03
+PKG_RELEASE:=1
 
 PKG_LICENSE:=GPL-2.0+
 PKG_LICENSE_FILES:=LICENSE
 
-include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pcapsipdump
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Telephony
-  DEPENDS:=+libpcap $(CXX_DEPENDS)
-  TITLE:=SIP sessions dumping tool
+  DEPENDS:=+libstdcpp +USE_GLIBC:libbsd +libpcap
+  TITLE:=SIP Sessions Dumping Tool
   URL:=http://sourceforge.net/projects/pcapsipdump/
 endef
 
 define Package/pcapsipdump/description
- pcapsipdump is a tool for dumping SIP sessions (+RTP traffic, if available) to disk in a
- fashion similar to "tcpdump -w" (format is exactly the same), but one file per sip session
- (even if there is thousands of concurrect SIP sessions).
+ pcapsipdump is a tool for dumping SIP sessions (plus RTP traffic, if
+ available) to disk in a fashion similar to "tcpdump -w" (format is
+ exactly the same), but one file per SIP session (even if there are
+ thousands of concurrent SIP sessions).
 endef
 
-MAKE_FLAGS += \
-       CC="$(TARGET_CXX)" \
-       CPPFLAGS="$(TARGET_CXXFLAGS) -fno-rtti $(TARGET_CPPFLAGS)" \
-       LIBS="-lpcap"
+MAKE_FLAGS+=LIBS="-lpcap"
 
 define Package/pcapsipdump/install
        $(INSTALL_DIR) $(1)/usr/bin