[packages] btpd: Fix a typo in init script
[openwrt/svn-archive/archive.git] / net / portmap / Makefile
index 05b19c4471daf3470217544ac6200a07a6cb212d..408722dc771d5d8753d3030d1887851cec2228fc 100644 (file)
@@ -1,24 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=portmap
-PKG_VERSION:=5beta
+PKG_VERSION:=6.0
 PKG_RELEASE:=2
-PKG_MD5SUM:=781e16ed4487c4caa082c6fef09ead4f
 
-PKG_SOURCE_URL:=ftp://ftp.porcupine.org/pub/security
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://neil.brown.name/portmap/
+PKG_MD5SUM:=ac108ab68bf0f34477f8317791aaf1ff
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,25 +23,26 @@ define Package/portmap
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libwrap
-  TITLE:=RPC Portmapper
-  DESCRIPTION:=The RPC Portmapper (used by the NFS Server)
-  URL:=ftp://ftp.porcupine.org/pub/security
+  TITLE:=The RPC Portmapper
+  URL:=http://neil.brown.name/portmap/
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -DHOSTS_ACCESS -DFACILITY=LOG_DAEMON -DIGNORE_SIGCHLD" \
-               WRAP_LIB="-L$(STAGING_DIR)/usr/lib -lwrap" \
-               all
+define Package/portmap/description
+ Portmap is a server that converts RPC (Remote Procedure Call) program
+ numbers into DARPA protocol port numbers.
 endef
 
-define Package/portmap/install 
-       install -d -m0755 $(1)/etc/init.d 
-       install -m0755 ./files/portmap.init $(1)/etc/init.d/portmap
-       ln -sf portmap $(1)/etc/init.d/S59portmap
-       install -d -m0755 $(1)/usr/sbin 
-       install -m0755 $(PKG_BUILD_DIR)/portmap $(1)/usr/sbin/
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -DHOSTS_ACCESS -DFACILITY=LOG_DAEMON -DIGNORE_SIGCHLD" \
+       RPCUSER="nobody" \
+       WRAP_LIB="$(TARGET_LDFLAGS) -lwrap" \
+       all
+
+define Package/portmap/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/portmap $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/portmap.init $(1)/etc/init.d/portmap
 endef
 
 $(eval $(call BuildPackage,portmap))