[packages] quagga-unstable: Update to v0.99.16
[openwrt/svn-archive/archive.git] / net / portsentry / Makefile
index e1f77d6f4b5029d1b97cd22e1dac8c5f9f4baa15..0f1d61338d203119409a11ae212f95d65324aaff 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,7 +14,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-1.2.tar.gz
 PKG_SOURCE_URL:=@SF/sentrytools
 PKG_MD5SUM:=3ebd3618ba9abfea2525e236bd44cebd
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_beta
 
@@ -32,16 +30,13 @@ define Package/portsentry/conffiles
 /etc/portsentry.conf
 endef
 
-define Build/Configure
-endef
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) linux
-endef
+MAKE_FLAGS += \
+       linux \
 
 define Package/portsentry/install      
-       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(1)/etc/
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
 endef