tor-alpha: remove obsolete package
[openwrt/svn-archive/packages.git] / net / pptpd / Makefile
index 2070acc0c837383f5629cdd0420b4b967b1a275a..2a44c7cb5703d992c0c9db3e5800beedf48be758 100644 (file)
@@ -1,62 +1,66 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptpd
-PKG_VERSION:=1.3.0
+PKG_VERSION:=1.4.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/poptop
-PKG_MD5SUM:=75d494e881f7027f4e60b114163f6b67
+PKG_MD5SUM:=36f9f45c6ffa92bc3b6e24ae2d053505
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pptpd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+kmod-ppp +kmod-gre
+  DEPENDS:=+kmod-ppp +kmod-gre +kmod-mppe +ppp
   TITLE:=PopTop pptp server
   URL:=http://www.poptop.org/
-  SUBMENU:=vpn
+  SUBMENU:=VPN
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-bcrelay \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-bcrelay \
+
+CONFIGURE_VARS += \
+       ac_cv_header_libintl_h=no \
+
+MAKE_FLAGS += \
+       COPTS="$(TARGET_CFLAGS)" \
+       INSTALL="install" \
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               COPTS="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               INSTALL="install" \
-               all install \
-       )
+define Package/pptpd/conffiles
+/etc/pptpd.conf
+/etc/ppp/options.pptpd
+/etc/config/pptpd
 endef
 
 define Package/pptpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(1)/usr/sbin/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/sbin/bcrelay \
+               $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl \
+               $(PKG_INSTALL_DIR)/usr/sbin/pptpd \
+               $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib/pptpd
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pptpd/* $(1)/usr/lib/pptpd
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pptpd/* $(1)/usr/lib/pptpd/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/pptpd.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/pptpd.init $(1)/etc/init.d/pptpd
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_DATA) ./files/options.pptpd $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/pptpd.config $(1)/etc/config/pptpd
 endef
 
 $(eval $(call BuildPackage,pptpd))