[package] move proftpd to the FTP submenu (follow-up of #5617)
[openwrt/svn-archive/archive.git] / net / privoxy / Makefile
index de22a6a1b18cddb9b43972991e07a060a35e16ac..3e505bef3081cc8330c942134754d7542d176ac8 100644 (file)
@@ -1,24 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=privoxy
-PKG_VERSION:=3.0.6
-PKG_RELEASE:=3
+PKG_VERSION:=3.0.12
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
 PKG_SOURCE_URL:=@SF/ijbswa
-PKG_MD5SUM:=c3b34c620e1174f0c0b91aa2a04ceae4
-PKG_CAT:=zcat
+PKG_MD5SUM:=c973e608d27b248ef567b47664308da1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,16 +24,18 @@ define Package/privoxy
   CATEGORY:=Network
   DEPENDS:=+libpcre +libpthread
   TITLE:=web proxy with advanced filtering capabilities
-  DESCRIPTION:=\
-       Privoxy is a web proxy with advanced filtering capabilities for \\\
-       protecting privacy, modifying web page content, managing cookies, \\\
-       controlling access, and removing ads, banners, pop-ups and other \\\
-       obnoxious Internet junk. Privoxy has a very flexible configuration \\\
-       and can be customized to suit individual needs and tastes. Privoxy \\\
-       has application for both stand-alone systems and multi-user networks.
   URL:=http://www.privoxy.org/
 endef
 
+define Package/privoxy/description
+       Privoxy is a web proxy with advanced filtering capabilities for 
+       protecting privacy, modifying web page content, managing cookies, 
+       controlling access, and removing ads, banners, pop-ups and other 
+       obnoxious Internet junk. Privoxy has a very flexible configuration 
+       and can be customized to suit individual needs and tastes. Privoxy 
+       has application for both stand-alone systems and multi-user networks.
+endef
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                autoheader && autoconf \
@@ -46,9 +45,9 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               SPECIAL_CFLAGS="-pthread -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib"
+               SPECIAL_CFLAGS="-pthread $(TARGET_LDFLAGS)"
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -57,12 +56,11 @@ endef
 
 define Package/privoxy/conffiles
 /etc/privoxy/config
-/etc/privoxy/user.action
 endef
 
 define Package/privoxy/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/privoxy
        $(CP) $(PKG_INSTALL_DIR)/etc/privoxy/* $(1)/etc/privoxy/
        $(INSTALL_CONF) ./files/privoxy.config $(1)/etc/privoxy/config