[packages] nano: update to 2.2.3
[openwrt/svn-archive/archive.git] / net / privoxy / Makefile
index 04813699b328ede0228d6a4036846d5451b57963..3e505bef3081cc8330c942134754d7542d176ac8 100644 (file)
@@ -1,24 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=privoxy
-PKG_VERSION:=3.0.3
+PKG_VERSION:=3.0.12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
 PKG_SOURCE_URL:=@SF/ijbswa
-PKG_MD5SUM:=b0710be8af09409bfb03f52523a17010
-PKG_CAT:=zcat
+PKG_MD5SUM:=c973e608d27b248ef567b47664308da1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,61 +24,48 @@ define Package/privoxy
   CATEGORY:=Network
   DEPENDS:=+libpcre +libpthread
   TITLE:=web proxy with advanced filtering capabilities
-  DESCRIPTION:=\
-       Privoxy is a web proxy with advanced filtering capabilities for \\\
-       protecting privacy, modifying web page content, managing cookies, \\\
-       controlling access, and removing ads, banners, pop-ups and other \\\
-       obnoxious Internet junk. Privoxy has a very flexible configuration \\\
-       and can be customized to suit individual needs and tastes. Privoxy \\\
-       has application for both stand-alone systems and multi-user networks.
   URL:=http://www.privoxy.org/
 endef
 
+define Package/privoxy/description
+       Privoxy is a web proxy with advanced filtering capabilities for 
+       protecting privacy, modifying web page content, managing cookies, 
+       controlling access, and removing ads, banners, pop-ups and other 
+       obnoxious Internet junk. Privoxy has a very flexible configuration 
+       and can be customized to suit individual needs and tastes. Privoxy 
+       has application for both stand-alone systems and multi-user networks.
+endef
+
 define Build/Configure
-  (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
-                autoheader && autoconf && \
-                $(TARGET_CONFIGURE_OPTS) \
-                CFLAGS="$(strip $(TARGET_CFLAGS))" \
-                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-                ./configure \
-                  --target=$(GNU_TARGET_NAME) \
-                  --host=$(GNU_TARGET_NAME) \
-                  --build=$(GNU_HOST_NAME) \
-                  --program-prefix="" \
-                  --program-suffix="" \
-                  --prefix=/usr \
-                  --exec-prefix=/usr \
-                  --bindir=/usr/bin \
-                  --datadir=/usr/share \
-                  --includedir=/usr/include \
-                  --infodir=/usr/share/info \
-                  --libdir=/usr/lib \
-                  --libexecdir=/usr/lib \
-                  --localstatedir=/var \
-                  --mandir=/usr/share/man \
-                  --sbindir=/usr/sbin \
-                  --sysconfdir=/etc \
-                  $(DISABLE_NLS) \
-                  --disable-static \
-        );
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               autoheader && autoconf \
+       );
+       $(call Build/Configure/Default, \
+               --sysconfdir=/etc/privoxy \
+       )
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               SPECIAL_CFLAGS="-pthread -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib"
+               SPECIAL_CFLAGS="-pthread $(TARGET_LDFLAGS)"
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                install
 endef
 
-define Package/privoxy/install 
-       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/privoxy  $(1)/etc/init.d
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(1)/usr/sbin/
-       $(CP) ./files/$(PKG_NAME).config $(1)/etc/privoxy/config
-       $(CP) $(PKG_BUILD_DIR)/default.filter $(1)/etc/privoxy/
-       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
+define Package/privoxy/conffiles
+/etc/privoxy/config
+endef
+
+define Package/privoxy/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/privoxy
+       $(CP) $(PKG_INSTALL_DIR)/etc/privoxy/* $(1)/etc/privoxy/
+       $(INSTALL_CONF) ./files/privoxy.config $(1)/etc/privoxy/config
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/privoxy.init $(1)/etc/init.d/privoxy
 endef
 
 $(eval $(call BuildPackage,privoxy))