mark rtorrent as broken until somebody fixes it
[openwrt/svn-archive/archive.git] / net / privoxy / Makefile
index de22a6a1b18cddb9b43972991e07a060a35e16ac..91e2092bf8d12aa23f4db7bdd2ff1b81f686720b 100644 (file)
@@ -9,16 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=privoxy
-PKG_VERSION:=3.0.6
+PKG_VERSION:=3.0.8
 PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
 PKG_SOURCE_URL:=@SF/ijbswa
-PKG_MD5SUM:=c3b34c620e1174f0c0b91aa2a04ceae4
-PKG_CAT:=zcat
+PKG_MD5SUM:=252c0e085218fb930c4bc7563e9cedd9
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,16 +25,18 @@ define Package/privoxy
   CATEGORY:=Network
   DEPENDS:=+libpcre +libpthread
   TITLE:=web proxy with advanced filtering capabilities
-  DESCRIPTION:=\
-       Privoxy is a web proxy with advanced filtering capabilities for \\\
-       protecting privacy, modifying web page content, managing cookies, \\\
-       controlling access, and removing ads, banners, pop-ups and other \\\
-       obnoxious Internet junk. Privoxy has a very flexible configuration \\\
-       and can be customized to suit individual needs and tastes. Privoxy \\\
-       has application for both stand-alone systems and multi-user networks.
   URL:=http://www.privoxy.org/
 endef
 
+define Package/privoxy/description
+       Privoxy is a web proxy with advanced filtering capabilities for 
+       protecting privacy, modifying web page content, managing cookies, 
+       controlling access, and removing ads, banners, pop-ups and other 
+       obnoxious Internet junk. Privoxy has a very flexible configuration 
+       and can be customized to suit individual needs and tastes. Privoxy 
+       has application for both stand-alone systems and multi-user networks.
+endef
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                autoheader && autoconf \
@@ -62,7 +62,7 @@ endef
 
 define Package/privoxy/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/privoxy
        $(CP) $(PKG_INSTALL_DIR)/etc/privoxy/* $(1)/etc/privoxy/
        $(INSTALL_CONF) ./files/privoxy.config $(1)/etc/privoxy/config