[packages] memcached: update to 1.4.11 (#10804), add missing libpthread dependency...
[openwrt/svn-archive/archive.git] / net / prosody / Makefile
index a8d59c902cefa2df291dabb84da7eab0715e2e07..025a3e45a89b3bf788689442d28845056e733cb9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,21 +8,24 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=prosody
-PKG_VERSION:=0.5.2
-PKG_RELEASE:=1
+PKG_VERSION:=0.6.2
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://prosody.im/downloads/source/
-PKG_MD5SUM:=bcc7828c041e53b2c909822b1acdf600
+PKG_SOURCE_URL:=http://prosody.im/downloads/source
+PKG_MD5SUM:=5da59bc906419ad3b4faa21516a6ca18
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/prosody
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+liblua +libidn +libopenssl +luasocket +luaexpat +luasec
+  SUBMENU:=Instant Messaging
+  DEPENDS:=+luafilesystem +libidn +luaexpat +luasec
   TITLE:=XMPP server
-  URL:=http://prosody.im
+  URL:=http://prosody.im/
 endef
 
 define Package/prosody/description
@@ -45,24 +48,23 @@ define Build/Configure
                --with-lua-include="$(STAGING_DIR)/usr/include" \
                --with-lua-lib="$(STAGING_DIR)/usr/lib" \
                --cflags="$(TARGET_CFLAGS)" \
+               --datadir="/etc/prosody/data" \
        )
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default,\
-               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               PREFIX="/usr" \
-               all install \
-       )
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -std=gnu99" \
+       LDFLAGS="$(TARGET_LDFLAGS)" \
+       PREFIX="/usr" \
 
 define Package/prosody/install
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/prosody.init $(1)/etc/init.d/prosody
        $(INSTALL_DIR) $(1)/etc/prosody
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/prosody/prosody.cfg.lua $(1)/etc/prosody/
        $(INSTALL_DIR) $(1)/etc/prosody/certs
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/prosody/certs/localhost.{cert,key} $(1)/etc/prosody/certs/
+       $(INSTALL_DIR) $(1)/etc/prosody/data
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/prosody{,ctl} $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/prosody
@@ -73,10 +75,13 @@ define Package/prosody/install
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/fallbacks/*.lua $(1)/usr/lib/prosody/fallbacks/
        $(INSTALL_DIR) $(1)/usr/lib/prosody/modules
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/modules/*.lua $(1)/usr/lib/prosody/modules/
+       $(INSTALL_DIR) $(1)/usr/lib/prosody/modules/muc
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/modules/muc/*.lua $(1)/usr/lib/prosody/modules/muc/
        $(INSTALL_DIR) $(1)/usr/lib/prosody/net
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/net/*.lua $(1)/usr/lib/prosody/net/
        $(INSTALL_DIR) $(1)/usr/lib/prosody/util
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/*.{lua,so} $(1)/usr/lib/prosody/util/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/*.lua $(1)/usr/lib/prosody/util/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/*.so $(1)/usr/lib/prosody/util/
 endef
 
 $(eval $(call BuildPackage,prosody))