add a patch to prevent the wrapper from linking when generating dep files
[openwrt/svn-archive/archive.git] / net / psybnc / Makefile
index 76b0bc846c0b41873a5d8625cf935b9f8641fcdf..d80d81e6dbddff3992f9bf69cb1c915fde167a71 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=psybnc
 PKG_VERSION:=2.3.2-7
 PKG_RELEASE:=1
-PKG_MD5SUM:=4b893a92f914813450e0921b2894ad6c
 
-PKG_SOURCE_URL:=http://www.psybnc.info/download/beta/
 PKG_SOURCE:=psyBNC-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.psybnc.info/download/beta/
+PKG_MD5SUM:=4b893a92f914813450e0921b2894ad6c
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
@@ -26,30 +26,31 @@ define Package/psybnc
   CATEGORY:=Network
   DEPENDS:=
   TITLE:=An IRC-Bouncer with many features
-  DESCRIPTION:=psyBNC is an easy-to-use, multi-user, permanent\\\
-       IRC-Bouncer with many features. Some of its features\\\
-       vhost- and relay support to connected bouncers and an\\\
-       extensive online help system. Many other helpful\\\
-       functions are included.\\\
+  DESCRIPTION:=\
+       psyBNC is an easy-to-use, multi-user, permanent \\\
+       IRC-Bouncer with many features. Some of its features \\\
+       vhost- and relay support to connected bouncers and an \\\
+       extensive online help system. Many other helpful \\\
+       functions are included.
   URL:=http://www.psybnc.info/
 endef
 
 define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
+       $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS)" \
                HOSTCC="$(HOSTCC)" \
-               all
+               all \
+       )
 endef
 
 define Package/psybnc/install  
-       install -d -m0755 $(1)/usr/share/psybnc/lang/
-       install -d -m0755 $(1)/usr/share/psybnc/log/
-       install -d -m0755 $(1)/usr/sbin/
-       install -m0755 $(PKG_BUILD_DIR)/psybnc $(1)/usr/share/psybnc/
-       install -m0600 $(PKG_BUILD_DIR)/psybnc.conf $(1)/usr/share/psybnc/
-       install -m0644 $(PKG_BUILD_DIR)/lang/english.lng $(1)/usr/share/psybnc/lang/
-       install -m0755 $(PKG_BUILD_DIR)/psybnc.sh $(1)/usr/sbin/psybnc
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/psybnc.sh $(1)/usr/sbin/psybnc
+       $(INSTALL_DIR) $(1)/usr/share/psybnc
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/psybnc $(1)/usr/share/psybnc/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/psybnc.conf $(1)/usr/share/psybnc/
+       $(INSTALL_DIR) $(1)/usr/share/psybnc/lang
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/lang/english.lng $(1)/usr/share/psybnc/lang/
 endef
 
 $(eval $(call BuildPackage,psybnc))