[package] update st2205tool to 1.4.3 (#5731)
[openwrt/svn-archive/archive.git] / net / quagga / Makefile
index 119c1d8e1c2f5f579f6bdab0e3ce1ed33efe6b15..0815ebab4f3746c9b96b06d49090b5816b9975eb 100644 (file)
@@ -1,26 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=quagga
 PKG_VERSION:=0.98.6
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 PKG_MD5SUM:=b0d4132039953a0214256873b7d23d68
 
 PKG_SOURCE_URL:=http://www.quagga.net/download/ \
                 http://www.de.quagga.net/download/ \
                 http://www.uk.quagga.net/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -39,10 +34,9 @@ define Package/quagga
 endef
 
 define Package/quagga/description
-A routing software package that provides TCP/IP based routing services
+       A routing software package that provides TCP/IP based routing services
        with routing protocols support such as RIPv1, RIPv2, RIPng, OSPFv2,
        OSPFv3, BGP-4, and BGP-4+
-
 endef
 
 define Package/quagga-libzebra
@@ -102,7 +96,6 @@ define Build/Configure
                --sysconfdir=/etc/quagga/ \
                --enable-shared \
                --disable-static \
-               --enable-ipv6 \
                --enable-vtysh \
                --enable-user=quagga \
                --enable-group=quagga \
@@ -111,19 +104,20 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR=$(PKG_INSTALL_DIR) \
                all install
 endef
 
-define Package/quagga/install  
+define Package/quagga/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/zebra $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/watchquagga $(1)/usr/sbin/
        # avoid /etc being set to 0750
        $(INSTALL_DIR) $(1)/etc/quagga/
        chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/zebra.conf
        $(INSTALL_DIR) $(1)/etc/init.d/
        $(INSTALL_BIN) ./files/quagga $(1)/usr/sbin/quagga.init
        $(INSTALL_BIN) ./files/quagga.init $(1)/etc/init.d/quagga
@@ -178,37 +172,55 @@ echo "isisd         2608/tcp" >>$${IPKG_INSTROOT}/etc/services
 fi
 endef
 
-define Package/quagga-bgpd/install     
+define Package/quagga-bgpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/bgpd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/quagga/
+       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/bgpd.conf
 endef
 
 define Package/quagga-isisd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/isisd $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/etc/quagga/
+       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/isisd.conf
 endef
 
-define Package/quagga-ospfd/install    
+define Package/quagga-ospfd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ospfd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/quagga/
+       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/ospfd.conf
 endef
 
-define Package/quagga-ospf6d/install   
+define Package/quagga-ospf6d/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ospf6d $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/quagga/
+       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/ospf6d.conf
 endef
 
-define Package/quagga-ripd/install     
+define Package/quagga-ripd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ripd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/quagga/
+       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/ripd.conf
 endef
 
-define Package/quagga-ripngd/install   
+define Package/quagga-ripngd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ripngd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/quagga/
+       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/ripngd.conf
 endef
 
-define Package/quagga-vtysh/install    
+define Package/quagga-vtysh/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/vtysh $(1)/usr/bin/
 endef