fix last commit, move patch to correct package
[openwrt/svn-archive/archive.git] / net / raddump / Makefile
index 2a9973fdb3740e4838c358e8ac085c4f2eace27b..7d7a87690fa920e483279ec2185613a7335b651e 100644 (file)
@@ -15,10 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/raddump
 PKG_MD5SUM:=f8c29c67141ea78bb6ae8b97d5149480
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,14 +23,16 @@ define Package/raddump
   CATEGORY:=Network
   DEPENDS:=+libpcap +libopenssl
   TITLE:=raddump interprets captured RADIUS packets.
-  DESCRIPTION:=\
-       raddump interprets captured RADIUS packets to print a \\\
-       timestamp, packet length, RADIUS packet type, source and \\\
-       destination hosts and ports, and included attribute names and \\\
-       values for each packet.
   URL:=http://sourceforge.net/projects/raddump
 endef
 
+define Package/raddump/description
+       raddump interprets captured RADIUS packets to print a 
+       timestamp, packet length, RADIUS packet type, source and 
+       destination hosts and ports, and included attribute names and 
+       values for each packet.
+endef
+
 # uses GNU configure
 
 define Build/Compile   
@@ -44,8 +42,8 @@ define Build/Compile
 endef
 
 define Package/raddump/install 
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/raddump $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/raddump $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,raddump))