[packages] prosody: update to 0.6.2, add an init script, enable the posix module...
[openwrt/svn-archive/archive.git] / net / rp-l2tp / Makefile
index 12eaa616fe624a5056191ffc3a587d783341746d..d120c342ab7bd3979c8d139175e0b39f242eea85 100644 (file)
@@ -1,59 +1,37 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rp-l2tp
 PKG_VERSION:=0.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/rp-l2tp
 PKG_MD5SUM:=0e45d11cb4fa6c56cce6b1d119733ed9
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/rp-l2tpd/Default
+define Package/rp-l2tpd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Roaring Penguin L2TP
-  DESCRIPTION:=\
-       Roaring Penguin L2TP (Layer 2 Tunneling Protocol) implementation.
   URL:=http://sourceforge.net/projects/rp-l2tp/
-endef
-
-define Package/rp-l2tpd
-  $(call Package/rp-l2tpd/Default)
   TITLE+= daemon
-  MENU:=1
+  SUBMENU:=dial-in/up
 endef
 
-define Package/rp-l2tpd-mod-cmd
-  $(call Package/rp-l2tpd/Default)
-  DEPENDS:=rp-l2tpd
-  TITLE:=Simple command handler for the RR L2TP daemon
-endef
-
-define Package/rp-l2tpd-mod-ppp
-  $(call Package/rp-l2tpd/Default)
-  DEPENDS:=rp-l2tpd
-  TITLE:=PPP handler for the RR L2TP daeomon
+define Package/rp-l2tpd/description
+       Roaring Penguin L2TP (Layer 2 Tunneling Protocol) implementation.
 endef
 
-# uses GNU configure
-MAKE_FLAGS += \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install
-
 TARGET_CFLAGS := -I$(PKG_BUILD_DIR)/libevent $(TARGET_CFLAGS)
 
 define Package/rp-l2tpd/install        
@@ -61,23 +39,26 @@ define Package/rp-l2tpd/install
        $(CP) $(PKG_INSTALL_DIR)/etc/l2tp.conf.example $(1)/etc/l2tp.conf
        $(INSTALL_DIR) $(1)/usr/lib/l2tp
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/l2tpd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/rp-l2tpd.init $(1)/etc/init.d/rp-l2tpd
-endef
-
-define Package/rp-l2tpd-mod-cmd/install        
-       $(INSTALL_DIR) $(1)/usr/lib/l2tp
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/cmd.so $(1)/usr/lib/l2tp/
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
-endef
-
-define Package/rp-l2tpd-mod-ppp/install
-       $(INSTALL_DIR) $(1)/usr/lib/l2tp
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/sync-pppd.so $(1)/usr/lib/l2tp/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
 endef
 
+#define Package/rp-l2tpd-mod-cmd/install       
+#      $(INSTALL_DIR) $(1)/usr/lib/l2tp
+#      $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/cmd.so $(1)/usr/lib/l2tp/
+#      $(INSTALL_DIR) $(1)/usr/sbin
+#      $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
+#endef
+
+#define Package/rp-l2tpd-mod-ppp/install
+#      $(INSTALL_DIR) $(1)/usr/lib/l2tp
+#      $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/sync-pppd.so $(1)/usr/lib/l2tp/
+#endef
+
 $(eval $(call BuildPackage,rp-l2tpd))
-$(eval $(call BuildPackage,rp-l2tpd-mod-cmd))
-$(eval $(call BuildPackage,rp-l2tpd-mod-ppp))
+#$(eval $(call BuildPackage,rp-l2tpd-mod-cmd))
+#$(eval $(call BuildPackage,rp-l2tpd-mod-ppp))