rtpengine: bump to LTS version 9.5.1.3
[feed/telephony.git] / net / rtpengine / Makefile
index e03169838f3ecc5ce7258c12a61a15516bd2c650..e35b511284338f68be1da7bdaffe5919d862b791 100644 (file)
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=rtpengine
-PKG_VERSION:=8.5.3.3
+PKG_VERSION:=9.5.1.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-mr$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/sipwise/rtpengine/tar.gz/mr$(PKG_VERSION)?
-PKG_HASH:=754711a46fc50001b2e840521d3b6fd654cb2f9da11924ca40d8e165fba6bd98
+PKG_HASH:=c9b07f120703429351abc120da71e4e72d4d9b8d72ec689a3cd61ab3030545c6
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-mr$(PKG_VERSION)
 
@@ -48,6 +48,7 @@ ENGINE_DEPENDS := \
        +libopenssl \
        +libpcap \
        +libpcre \
+       +libwebsockets \
        +xmlrpc-c-client \
        +zlib
 
@@ -56,15 +57,18 @@ ENGINE_DEPENDS_TRANSCODING := \
        +bcg729 \
        +libffmpeg-full \
        +libmariadb \
-       +libspandsp
+       +libspandsp3
 
 RECORDING_DEPENDS := \
+       +bcg729 \
        +glib2 \
        +libffmpeg-full \
        +libmariadb \
        +libopenssl
 
-RTPENGINE_USERID:=$(PKG_NAME)=378:$(PKG_NAME)=378
+RTPENGINE_USERID:=378
+RTPENGINE_GROUPID:=$(RTPENGINE_USERID)
+RTPENGINE_USER:=$(PKG_NAME)=$(RTPENGINE_USERID):$(PKG_NAME)=$(RTPENGINE_GROUPID)
 
 define Package/rtpengine/Default
   URL:=https://github.com/sipwise/rtpengine
@@ -76,7 +80,7 @@ $(call Package/rtpengine/Default)
   CATEGORY:=Network
   SECTION:=net
   SUBMENU:=Telephony
-  USERID:=$(RTPENGINE_USERID)
+  USERID:=$(RTPENGINE_USER)
 endef
 
 define Package/rtpengine/description/Template
@@ -155,7 +159,7 @@ $(call Package/rtpengine/Default)
   CATEGORY:=Network
   SECTION:=net
   SUBMENU:=Telephony
-  USERID:=$(RTPENGINE_USERID)
+  USERID:=$(RTPENGINE_USER)
   DEPENDS:=$(patsubst +%,+PACKAGE_rtpengine-recording:%,$(RECORDING_DEPENDS))
 endef
 
@@ -206,11 +210,17 @@ $(call Package/rtpengine/Default)
   FILES:=$(PKG_BUILD_DIR)/kernel-module/xt_RTPENGINE.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoProbe,xt_RTPENGINE)
   DEPENDS := \
+         +PACKAGE_kmod-ipt-rtpengine:kmod-crypto-aead \
          +PACKAGE_kmod-ipt-rtpengine:kmod-crypto-hash \
          +PACKAGE_kmod-ipt-rtpengine:kmod-ipt-core
   MODPARAMS.xt_RTPENGINE := \
-         proc_uid=$(PKG_NAME) \
-         proc_gid=$(PKG_NAME)
+         proc_uid=$(RTPENGINE_USERID) \
+         proc_gid=$(RTPENGINE_GROUPID)
+  USERID:=$(RTPENGINE_USER)
+endef
+
+define KernelPackage/ipt-rtpengine/conffiles
+/etc/modules.d/ipt-rtpengine
 endef
 
 define KernelPackage/ipt-rtpengine/description