rtpproxy: add init script and UCI config
[feed/telephony.git] / net / rtpproxy / Makefile
index 88fce3e4c9a7f2077b07752ba5d4a1737b727d4a..2fa30144145100cd8ad0b62a0fad6d58f4c7e8b4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,17 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rtpproxy
 PKG_VERSION:=1.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://b2bua.org/chrome/site/
 PKG_MD5SUM:=b0b5d6cdce3f17cdbbac473c11a2d0e5
-
+PKG_CHECK_FORMAT_SECURITY:=0
 PKG_INSTALL:=1
 
+PKG_LICENSE:=BSD-2-Clause
+PKG_LICENSE_FILES:=COPYING
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/rtpproxy
@@ -28,11 +31,15 @@ define Package/rtpproxy
   URL:=http://www.rtpproxy.org/
 endef
 
-# uses GNU configure
-
 define Package/rtpproxy/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rtpproxy $(1)/usr/bin/
+
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/rtpproxy.init $(1)/etc/init.d/rtpproxy
+
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_BIN) ./files/rtpproxy.config $(1)/etc/config/rtpproxy
 endef
 
 $(eval $(call BuildPackage,rtpproxy))