[packages] transmission: update to 1.93
[openwrt/svn-archive/archive.git] / net / sipp / Makefile
index 673c192e1448276da1d37b829aea48392437ffe0..92386c2044a659eeaa0836b0881fe705db717468 100644 (file)
@@ -4,51 +4,55 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sipp
-PKG_VERSION:=1.0
+PKG_VERSION:=3.1
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).src.tar.gz
 PKG_SOURCE_URL:=@SF/sipp
-PKG_MD5SUM:=8866e9af0d3bc29e91ebb6eab89a7f1f
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_MD5SUM:=452a6f88f2d314dbb2f44e318a60982b
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/sipp
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+uclibcxx +libpthread +libncurses
+  DEPENDS:= +libncurses +libpthread +uclibcxx
   TITLE:=test tool / traffic generator for the SIP protocol
-  DESCRIPTION:=\
-       SIPp is a free Open Source test tool / traffic generator for the SIP protocol.\\\
-       It includes a few basic SipStone user agent scenarios (UAC and UAS) and\\\
-       establishes and releases multiple calls with the INVITE and BYE methods.\\\
-  URL:=http://sipp.sourceforge.net
+  URL:=http://sipp.sourceforge.net/
+endef
+
+define Package/sipp/description
+ SIPp is a free Open Source test tool / traffic generator for the SIP
+ protocol. It includes a few basic SipStone user agent scenarios (UAC and
+ UAS) and establishes and releases multiple calls with the INVITE and BYE
+ methods.
+endef
+
+TAR_CMD:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components 1 $(TAR_OPTIONS)
+
+define Build/Configure
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                CC_linux="$(TARGET_CC)" \
                CPP_linux="$(TARGET_CC)" \
                CCLINK_linux="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS_linux="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -fno-builtin -nostdinc++" \
-               LFLAGS_linux="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               LIBS="-luClibc++ -lc -lm -lgcc -lpthread -ldl -lncurses" \
+               CPPFLAGS_linux="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++" \
+               LFLAGS_linux="$(TARGET_LDFLAGS)" \
+               LIBS="-nodefaultlibs -lncurses -luClibc++ -ldl -lpthread -lm $(LIBGCC_S)" \
                all
 endef
 
-define Package/sipp/install    
+define Package/sipp/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sipp $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,sipp))