[package] siproxd: update to 0.8.1
[openwrt/svn-archive/archive.git] / net / siproxd / Makefile
index 828463fe46b200c9fb405e99152fb8d84e844526..adaa1651910b17cf99837c9ad650ca21453f422c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=siproxd
-PKG_VERSION:=0.7.1
-PKG_RELEASE:=3
-
+PKG_VERSION:=0.8.1
+PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/siproxd
-PKG_MD5SUM:=45e5a44803181e2bf3361d562060c904
+PKG_MD5SUM:=1a6f9d13aeb2d650375c9a346ac6cbaf
+
+PKG_BUILD_DEPENDS:=libosip2
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
@@ -24,17 +25,24 @@ define Package/siproxd
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Telephony
-  DEPENDS:=+libltdl +libosip2 +libpthread
+  DEPENDS:=+libltdl +libpthread
   TITLE:=SIP (Session Initiation Protocol) proxy
   URL:=http://siproxd.sourceforge.net/
 endef
 
+define Package/siproxd/description
+       Siproxd is a proxy/masquerading daemon for the SIP protocol.
+endef
+
 define Package/siproxd/conffiles
 /etc/config/siproxd
 endef
 
 CONFIGURE_ARGS+= \
+       --enable-static-libosip2 \
        --with-libosip-prefix="$(STAGING_DIR)/usr" \
+       --disable-doc \
+       --disable-shared
 
 MAKE_FLAGS+= \
        SUBDIRS="src scripts contrib" \
@@ -42,11 +50,9 @@ MAKE_FLAGS+= \
 
 define Package/siproxd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/siproxd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/usr/lib/siproxd
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/siproxd/plugin_*.so* $(1)/usr/lib/siproxd/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/siproxd $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/siproxd.config $(1)/etc/config/siproxd
+       $(INSTALL_CONF) ./files/siproxd.config $(1)/etc/config/siproxd
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/siproxd.init $(1)/etc/init.d/siproxd
 endef