appweb: fix a compile error
[openwrt/svn-archive/archive.git] / net / slurm / Makefile
index abeb1062d662dd7438a578ec2817cf8428575188..2f72362b86490929e7c0bb1b272a710cf9980028 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -13,12 +12,9 @@ PKG_VERSION:=0.3.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.wormulon.net/files/code/slurm/
+PKG_SOURCE_URL:=http://www.wormulon.net/slurm/
 PKG_MD5SUM:=e68d09202b835c644f7f6b7f070f29a2
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/slurm
@@ -26,7 +22,7 @@ define Package/slurm
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=A realtime network interface monitor
-  URL:=http://www.wormulon.net/projects/slurm
+  URL:=http://www.wormulon.net/slurm/
 endef
 
 define Package/slurm/description
@@ -61,7 +57,7 @@ endef
 
 define Package/slurm/install   
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/slurm $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/slurm $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,slurm))