openconnect: remove old network scripts
[openwrt/svn-archive/archive.git] / net / slurm / Makefile
index 35a709453c9c67fa7167fb983ca6c9eb382ef018..53096f0f05c2f27a3f472a925eb8e6f70434dda8 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -13,12 +12,10 @@ PKG_VERSION:=0.3.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.wormulon.net/files/code/slurm/
+PKG_SOURCE_URL:=http://www.wormulon.net/slurm/
 PKG_MD5SUM:=e68d09202b835c644f7f6b7f070f29a2
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,7 +24,7 @@ define Package/slurm
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=A realtime network interface monitor
-  URL:=http://www.wormulon.net/projects/slurm
+  URL:=http://www.wormulon.net/slurm/
 endef
 
 define Package/slurm/description
@@ -39,7 +36,7 @@ define Package/slurm/description
        - it's themeable.
 endef
 
-define Build/Configure 
+define Build/Configure
        (cd $(PKG_BUILD_DIR); touch \
                configure.in \
                aclocal.m4 \
@@ -54,15 +51,9 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/slurm/install   
+define Package/slurm/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/slurm $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/slurm $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,slurm))